ssl doesn't work and redirect to another domain

Discussion in 'Installation/Configuration' started by tonytroy, Mar 2, 2020.

  1. tonytroy

    tonytroy Member

    Hi there,

    I'm on a fresh new ISP config install on a debian 10 with apache, i added some websites (all on the same IP address) and one of them has SSL with let's encrypt, and it works.
    I tried to add another website with SSL (let's encrypt) and it's not working. When i go to the website settings the SSL and Let'sEncrypt options are not checked (i tried to check them 3 or 4 times, saving, but still not working) and when i try to join this new website via its URL, i'm automatically redirected to the first one with the SSL working.

    How can i make Let'sEncrypt work for more than one website ? Where can i manage this unwanted redirect ?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please try using the search function, the reasons for such behaviour are explained several times a week here in the forum and there is also a FAQ which guides you trough all steps to find out why LE rejects to issue an SSL cert.
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Use Internet Search Engines with
    Code: wrong website shown
    Or read forum posts from the weekend, I believe it was @till who just answered the same question.
    To get your LE cert working, use this:
    Which can be found with
    Code: lets encrypt error faq
  4. tonytroy

    tonytroy Member

    Thx guys for your answers.

    I already read the FAQ and a lot of posts but i'm still not able to find out a solution (i'm maybe not quite the detective).

    I actually have an issue with only 1 website, all others websites are working fine.

    I have WEBSITE_A on IP_ADDRESS_A with LE that is OK, WEBSITE_B on IP_ADDRESS_A with LE that is OK, WEBSITE_C (and 4 more) on IP_ADDRESS_A without LE that are OK.
    But when I try to add WEBSITE_I on IP_ADDRESS_A with LE it's not working. The SSL is automatically disabled and the URL is redirected. I tried to delete and re-create the website 4 times (so his webxx directory changed), and still the same error.

    I tried to add LE to another website and it worked.

    I have a default website in apache, I only have one IP address on the server, every other websites are working well, i only have problem with one and i can't find why. I looked at the log (/var/log/apache2, /var/log/ispconfig, /var/log/letsencrypt, /var/www/WEBSITE_I/log).
    The directory /var/www/WEBSITE_I/ssl is empty, when i created other LE certificate with ISPconfig, 3 files were added to each SSL directories..
    Every websites are pointing to the server on the IP (type A with @ and www).

    I thought the problem might come from the .fr TLD, but i just added another website, let's call it WEBSITE_M, that has a .fr TLD, and it worked fine oO

    Is there another log I didn't check ? I'm running out of ideas..

    Any help would be appreciated.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

  6. tonytroy

    tonytroy Member

    Thank you Till.

    I set ISPconfig in debug mode and when i tried to add SSL to the website i saw the problem "could not verify the domain". I tried to find why only this domain name was creating a problem without success (domain name was OK everywhere else, nslookup, etc.).

    So for anyone who read this, the only solution i found was to check the "Skip Let'sEncrypt validation" in the web > ssl settings.

    In my case, problem solved.

Share This Page