SSL DocumentRoot

Discussion in 'Installation/Configuration' started by tgansert, May 13, 2006.

  1. tgansert

    tgansert New Member

    I have CLEARLY set my DocumentRoot in Vhosts_ispconfig.conf to /usr/share/squirrelmail and yet I get an error 404 when I https://host.domain.tld/. Also, it doesn't work when I set DocumentRoot to /var/www/web1/squirrelmail when squirrelmail is symlinked to /usr/share/squirrelmail & I can't for the life of me enable the FollowSybolicLinks Option.... Is there a conf file somewhere that I am missing?!

    What gives? It works fine in http://host.domain.tld/.

    Also, the SSL isn't logging ANYTHING - so I don't even have a place to start.
  2. tgansert

    tgansert New Member

    ispconfig is completely ignoring any directives I give it in Vhosts...conf.

    In the http section, I put in aredirect to https, in the https section, I have a DocumentRoot that it is ignoring.

    After every change to conffiles, I am sure to /etc/init.d/ispconfig_server restart - but to no avail.

    How do I get ssl to work? How do I log ssl errors? How to I change DocumentRoot for ssl?

    I gave up on the redirect in http section and put it in a .htaccess file.
  3. tgansert

    tgansert New Member

    (for the record, all site certificatesd are created)
  4. falko

    falko Super Moderator ISPConfig Developer

    Don't change Vhosts_ispconfig.conf manually, it will be overwritten the next time you change something in ISPconfig. If you want to add additional directives, use ISPConfig's Apache Directives field.

    Have a look at the end of your main Apache configuration file. There are settings for the directories where ISPConfig puts your web sites. You can add the FollowSybolicLinks directive there. Restart Apache afterwards (your main Apache, not ISPConfig's Aapche!).

    You restarted the ISPConfig system, but not your main Apache. Of course, this cannot work.

Share This Page