SSL creation for Vhost

Discussion in 'Installation/Configuration' started by DreamK, Aug 25, 2008.

  1. DreamK

    DreamK New Member

    Hi everybody :)

    I try to set up a vhost with ispconfig but the vhost is created into the vhost.conf on :80.

    When I directly configure the virtualhost file there is no problem. But with the ispconfig update I loose the precious config.

    What I have done :

    1- I own my .ctr from
    Nom d'hôte: secure-ssl
    Domaine: domain.tld
    Adresse IP: 192.168.1.10 (single ssl/card)
    DNS: yes
    MX: yes
    ...
    ssl : yes

    2 -
    ##########################
    APACHE2 DIRECTIVE
    ##########################

    What Should I do ?
    - change the value of 80 to 443 into the SQL?
    - proceed in other way with ispconfig ?
    - configure apache 1.X from ispconfig with a default ssl folder ?

    My OS :
    - etch 4
    - 3 network cards


    See you
    Thanks in advance
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You missed to enable the SSL checkbox in ISPConfig for this vhost, then click on save, open the website configuration again and create a ssl certificate on the ssl tab. This is also described in the manuals, you find them all on the ispconfig.org documentation page.

    Inserting something to the apache directives box is not needed at all.
     
  3. DreamK

    DreamK New Member

    Hi Till,

    i have followed your advice without any result.

    I, I have reinstalled ISP with this hosts :

    ssl-security.domaine.tld with 443 enabled with ip 192.168.1.11
    www.domain.tld basicaly on port 80 with ip 192.168.1.10

    Results:
    - http://domain.tld ... shared ip page
    - http://www.domain.tld page ok
    - http://ssl-security.domain.tld unable to find the site

    Into the Vhost :
    - ssl-security.domain.tld is still listening 80

    Into error.log : nothing

    I try to find the entry into the SQL for forcing 443 listening, but I don t find them

    Regards
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    1) You missed to add a co-domain domain.tld (with empty hostname).
    2) Create a DNS A-Record for ssl-security.domain.tld that points to the IP of the server.

    Thats fine.
     
  5. DreamK

    DreamK New Member

    1
    co-domain for domain.tld was created correctly by ISP
    I just have checked the "create record" option


    That was done and that s work fine.

    Do you have another idea?
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Is domain.tld listed (without any hostname) in ServerName or ServerAlias in Vhosts_ispconfig.conf?

    Does
    Code:
    dig ssl-security.domaine.tld
    show the right IP address?
     
  7. DreamK

    DreamK New Member

    That s seems to be ok
    http://ssl-security.domaine.tld works perfectly on port 80
    ***but***
    https://ssl-security.domaine.tld unable to join the server
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Please post the output of the command:

    netstat -tap

    and a screenshot of the first tab of the configuration form of this website and a screenshot of the SSL tab of the configuration form of the site.
     
  9. DreamK

    DreamK New Member

    netstat -tap

     
  10. DreamK

    DreamK New Member

    Hi,

    I have checked the DB and all seems to be perfect and works perfectly.

    There is a way to keep and configure manually the following file : Vhosts_ispconfig.conf ?

    Regards
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    No, this file is managed automatically and ther is no need to edit it manually or at least the solution for your problem is not editing this file as many thousands of servers use the ISPConfig SSL functions without problems.

    Above you posted just the content of the first tab and not what you entered on the ssl tab. Just ticking the ssl checkbox is not enough, you must fill out the fields on the ssl tab and then select "Create certificate" as action and click on save.
     

Share This Page