ssl.conf error

Discussion in 'Installation/Configuration' started by dianer, Sep 18, 2005.

  1. dianer

    dianer New Member

    I installed apache2 per the instructions in the perfect setup for debian sarge...when I attempt to restart the apache server, I get an error message of:
    Forcing reload of web server: Apache2grep: /etc/apache2/mods=enabled/ssl.conf: No such file or directory.....
    apache2: could not open document config file /etc/apache2/mods-enabled/ssl.con
    There are processes named 'apache2' which do not match your pid file.

    Should I just remove apache2 and reinstall? :confused:
     
  2. falko

    falko Super Moderator

    Can you post the output of
    Code:
    ls -l /etc/apache2/mods-enabled
    and
    Code:
    ls -l /etc/apache2/mods-available
    here?

    Restart Apache, and if that doesn't help, reboot your system.
     
  3. dianer

    dianer New Member

    Apache


    I did that. I believe I figured out where the problem lies...when I added this line:
    ln -s /etc/apache2/mods-available/ssl.conf ssl.conf
    I typed mods-abailable instead....can I rename the file? If so, how do I do that?

    Thanks so much for your help.
     
  4. falko

    falko Super Moderator

    Do this:
    Code:
    cd /etc/apache2/mods-enabled
    rm -f ssl.conf
    ln -s /etc/apache2/mods-available/ssl.conf ssl.conf
    Then restart Apache.
     

Share This Page