SSL Certificates / Let's encrypt / SNI

Discussion in 'ISPConfig 3 Priority Support' started by Marcio Urakawa, Jul 23, 2020.

  1. Marcio Urakawa

    Marcio Urakawa Member HowtoForge Supporter

    For a given website, when I enable ssl and letsencrypt, ispconfig shows that it will update the configuration, but when I open the configuration right away, it is disabled.

    Does anyone have any clue as to what it could be?
    SNI is enabled.
     
  2. Th0m

    Th0m Active Member HowtoForge Supporter

  3. Marcio Urakawa

    Marcio Urakawa Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig has it's own port 8080, so it is not affected by a website SSL cert which uses port 443.
     
    Marcio Urakawa likes this.
  5. Marcio Urakawa

    Marcio Urakawa Member HowtoForge Supporter

    I changed to make ispconfig work on proto 443
     
    Last edited: Jul 23, 2020
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok. In this case you probably selected a wrong value in the IPv4 field of the website. when you mix * and IPv4 addresses on the server, then all sites that use * will become inaccessible. Remove the symlink to the website vhost in the apache or Nginx sites-enabled config directory, restart the web server, login to ISPConfig and correct that setting and press save.

    And you have seen now why we have chosen to not use port 443 for ISPConfig, because when you do that, you lose access to the control panel in case you misconfigure a website and you can not undo that easily due to the lost panel access.
     
    Marcio Urakawa likes this.
  7. Marcio Urakawa

    Marcio Urakawa Member HowtoForge Supporter

    I managed to solve it by changing the value * to the IP of the local server. Thank you always for helping.
     

Share This Page