ssl certificate problems

Discussion in 'General' started by nhybgtvfr, Jan 4, 2016.

  1. nhybgtvfr

    nhybgtvfr Member

    i have a problem with ssl certificates. i'm using the latest version of ispconfig3, standalone, on an ubuntu 14.04 server.
    i had a working site with a certificate, eg
    and a development site, eg, without a certificate.
    we had a reason for the dev site to go live, but needed the currently live site to remain available.

    i renamed to, gave that a few minutes to complete, then renamed to, gave that a few minutes, and then renamed to, purely because the dns was already setup and active for those two domain names, so we didn't need to wait for any dns propagation.

    the certificate settings still show up on the original sites ssl tab, key, csr, certificate, and bundle, are all populated, as are the domain, state, OU, etc.
    the new live site has exactly the same settings configured for state, locality, OU etc. and i've tried copy and pasting the key, csr, certificate, and bundle into the relevant fields on the new live site in various permutations, but i cannot get it to work, it has created some certificate files, but then creates another copy of the file with a .err extension. and it will not create any ssl settings in the sites conf file.

    what do i need to do to get this working properly?

    for now i've edited the conf file manually, so it's working, but it's obviously not a suitable long term solution.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    copy over the content of the ssl key, sl certificate and ssl bundle field from the live site to the dev site, the select "save certificate" as action and press the save button.

Share This Page