ssl certificate ispconfig 3

Discussion in 'Installation/Configuration' started by syduck, Jan 6, 2012.

  1. syduck

    syduck New Member

    Hi, i am trying to install a SSL certificate on my centos 5.5 ispconfig 3.

    I generated a csr through ispconfig, got my certificate from the CA and pasted it in the SSL Certificate section, marked action 'save certificate' and pressed save.
    Not sure what to do with the INTERMEDIATE certificate.

    Everything looks like it worked, the vhost file looks fine, when i restart apache i get:
    [warn] NameVirtualHost *:443 has no VirtualHosts
    [warn] NameVirtualHost*:443 has no VirtualHosts (fake ip)
    and when i try to browse to the https:// i get unable to connect.

    any ideas why its not working? thanks
  2. syduck

    syduck New Member


    The problem was mod_ssl was not installed, a yum install mod_ssl and a service httpd restart fixed it.

    As for the intermediate certificate I downloaded it and placed it on the server and added this line to the vhost as per the CA instructions.

    SSLCertificateChainFile /var/www/clients/client44/web60/ssl/intermediate.crt

Share This Page