SSL Apache2 Directive

Discussion in 'Server Operation' started by happz, Jan 29, 2014.

  1. happz

    happz Member

    I'm trying to install Godaddy SSL. There is no straight forward instruction but instead I came across many suggestions. One of those reports that I need to add a line in my apaches directive within ispconfi 3. So I did and most likely mistyped and now, I can't get to the server at all via the web.. I can port 22 and see my files and all but no more Https:// and of course no sites come up any more. I am not sure but if I just knew where to remove the line I might be able to resolve this.

    Can someone point me in the right direction?

  2. happz

    happz Member

    I don't mean to post on my post without waiting to see if anyone has an idea but I'm dead in the water. Whatever I did trying to install the ssl, it kill everything. I can't even get into my ispconfig3 control panel anymore..

    Any help would be appreciated.

    happz :)
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The steps are quite esay and do not require any editing of files or adding something in the apache directives field:

    1) Create a self signed ssl certificate on the ssl tab of the website.
    2) Wait a minute, then test that it works by connecting to the site with https.
    3) now copy the ssl csr from the ssl tab and let it sign from godaddy.
    4) you will receive a ssl cert file back from godaddy and a ssl bundle or chain file. copy the content of the ssl cert file into the ssl cert field on the ssl tab in ispconfig and the content of the ssl bundle file into the ssl bundle field in ispconfig, select "save certificate" in the action select field and click on save.
  4. happz

    happz Member

    Thank you, I will do that but currently I can't even get to ispconfig anymore. And none of my 16 websites. So, I need corrective steps.

    What got me in this mess was after I discovered the ssl no longer worked on the website in question, I started moving files around and had the godaddy cert rekeyed. I even deleted all the files in the websites ssl folder and removed the lines in-/etc/apache2/sites-available/

    I have tried to restart apache but it won't restart. The error says the certs are missing..

    Any ideas for me?

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Delete the vhost file were you added the ssl cert in /etc/apache2/sites-enabed/ flder and then restart apache and login to ispconfig.

    your problem is most likely caused by a ssl cert / key mismatch, as this will bring apache to halt completely for all sites.
  6. happz

    happz Member

    Okay, I will do that. Should I also delete the file in 'sites-enabled/100-website.... as well?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    I meant the file in the sites-enabled folder, just had a typo in the path :)
  8. happz

    happz Member

    Till, I delete both. Will I have trouble? Or better, what can I do now? And thank you for helping.. I can get to my other sites. now.

  9. till

    till Super Moderator Staff Member ISPConfig Developer

    ddisable the ssl checkbox in the settings of the site and click on save, this will recreate the site without ssl enabled. empty the ssl fields on the ssl tab of the site, select "delete certificates" as action and click save. this will delete the ssl cert. now you can enable ssl again for the site and start to create a new slef signed ssl cert like I described in my first post.
  10. happz

    happz Member

    Till, all worked out as you said it would. Thanks for you time and instructions.

    happz :)

Share This Page