SSL and internal server error

Discussion in 'Installation/Configuration' started by robertlouwen, Jul 7, 2009.

  1. robertlouwen

    robertlouwen New Member

    Gentlemen,

    I am on Fedora 10 with ISPConfig 3.0.1.3 and "host" 3 domains ( something.nl, something.nu and somethig.org )

    when I browse to https://www.something.nl or https://www.something.nu first I see a warning about certificates and safety then I click continue to website and the server returns a error 500 ( internal server error )
    when I browse to https://www.something.org first I see a warning about certificates and safety then I click continue to website and the server returns a error 404 ( page not found )

    When I view the certificates it says: : "issued to localhost.localdomain" and "issued by localhost.localdomain"

    Can anyone help me with this ?
     
  2. till

    till Super Moderator

    When you get an error, look at the error log of the website zo find out why you get this error.
     
  3. robertlouwen

    robertlouwen New Member

    @ Till,

    Will I find the log in ISPConfig ? or will I find it in /var/www/clients/clientx/webx/log ?
     
  4. Croydon

    Croydon HowtoForge Supporter

    try searching in
    /var/log/ispconfig/httpd/MYDOMAIN/error.log
     
  5. robertlouwen

    robertlouwen New Member

    @ Croydon,

    In error.log "louwen.nu" there is nothing after June 17 ???
    In error.log "louwen.org" there are a lot of errors but I can't see ( don't know ) wich is related to my problem.
    In error.log "runningchef.nl" there are the following errors:
    Code:
    Tue Jul 07 13:09:49 2009 [error] [client 192.168.0.1] SecurityException in Application.cpp:496: Handler not found in configuration
    Tue Jul 07 13:09:49 2009 [error] [client 192.168.0.1] Caused by KeyNotFoundException in configuration.cpp:234 Handler "x-httpdphp"not found
    Tue Jul 07 13:09:49 2009 [error] [client 192.168.0.1] Premature end of script headers: index.php File does not exist: /var/www/error/500.html
    I hope all this is helpfull to you
     
  6. falko

    falko Super Moderator

    Are you using suPHP? If so, what's in /etc/suphp.conf?
     
  7. robertlouwen

    robertlouwen New Member

    Re,

    @ Falko,

    I have enabled suPHP for all three domains in ISPconfig panel, if it works I don't know.

    The content of suphp.conf in attached .txt file.

    Thank you, again, for your time
    Robert
     

    Attached Files:

Share This Page