SSL and default apache page Issues

Discussion in 'Installation/Configuration' started by korbynn, Oct 4, 2010.

  1. korbynn

    korbynn Member

    Running lastest ISPConfig on CentOS 5.4. added 4 more IP's to list.

    I create the SSL certificate in the control panel for the site.
    I prefix the target site with https:// and do all of the accept certificate issues then the default apache 2 page comes up. Anything to resolve this problem?

    Also, is there any way of creating SSL certificates that would be recognized immediately by the web browses?

    Thanks in advance.
    Cheers,
    Korbynn
     
  2. till

    till Super Moderator

    Creating the ssl cert takes some time, so you might have to wait a few minutes until the ssl cert works. Beside that, check the vhost file for this website if it contains the vhost for ssl as well. If not, then there is a problem with the ssl certificate and you might have to recreate the ssl cert in ispconfig for this website. make sure that you do not use any special characters in the ssl fields as this might cause the ssl certificate creation to fail.

    Take the ssl certificate request that ispconfig created for you and let it sign by a ssl authority, e.g. startssl, thawte, instantssl, verisisgn, godaddy, etc...
     
  3. korbynn

    korbynn Member

    The problem is that the site is picking up my SSL certificate not the one that was generated.
     
  4. till

    till Super Moderator

    Then there must be some kind of default ssl vhost enabled on your server. Please check the httpd.conf and the includes directory if there is some kind of default ssl vhost from centos enabled.
     
  5. korbynn

    korbynn Member

    It seems that it takes about 15 minutes for the certificate to work.

    Now the problem is that the SSL provider is supplying a CA Certificate. Do I put this into the SSL Bundle or do I edit the vhost file directly?
     
  6. falko

    falko Super Moderator

    What kind of certificate is this?
     

Share This Page