SSI Not working in ISPConfig

Discussion in 'Installation/Configuration' started by makone, Oct 8, 2006.

  1. makone

    makone New Member

    Hi -
    I have an installation of ISPConfig - 2.2.6 , Cent OS 4.4, used the "Perfect Setup HowTo" procedure for the install. server side includes do not work in ISPconfig virtual sites. They do work on the shared IP or main IP based Apache sites. I have downloaded the test files, checked that PHP and PERL work, checked permissions, apache error logs, etc. SUEXEC is off. Everything else works great. Must be some kind of configuration issue. Anyone have any ideas? I have spent hours on this. Help! Thanks in advance.
     
    Last edited: Oct 8, 2006
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you enable SSI in the website settings?
     
  3. makone

    makone New Member

    ssi is checked in the website settings.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Can you post the vhost configuration (from Vhosts_ispconfig.conf) here?
    Did you disable SELinux on your system?
     
  5. makone

    makone New Member

    Thanks again to everyone who is helping here. I am still really stumped on this. This is not my first ISPconfig/CentOS server, and I have compared config files with the other servers where SSI is working, but still nothing I can see and no SSI on ISPconfig sites.

    SELinux is definitely turned off.

    Vhosts_ispconfig.conf partial excerpt:
    ###################################
    #
    # ISPConfig vHost Configuration File
    # Version 1.0
    #
    ###################################
    #
    NameVirtualHost 192.168.1.42:80
    <VirtualHost 192.168.1.42:80>
    ServerName localhost
    ServerAdmin [email protected]
    DocumentRoot /var/www/sharedip
    </VirtualHost>
    #
    #
    ######################################
    # Vhost: www.example.com:80
    ######################################
    #
    #
    <VirtualHost 192.168.1.42:80>
    ServerName www.example.com:80
    ServerAdmin [email protected]
    DocumentRoot /var/www/web5/web
    DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
    ScriptAlias /cgi-bin/ /var/www/web5/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    ErrorLog /var/www/web5/log/error.log
    AddType application/x-httpd-php .php .php3 .php4 .php5
    <Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    <Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
    </Files>
    php_admin_flag safe_mode Off
    AddType text/html .shtml
    AddOutputFilter INCLUDES .shtml
    AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
    AddType text/vnd.wap.wml .wml
    AddType text/vnd.wap.wmlscript .ws .wmlscript
    AddType image/vnd.wap.wbmp .wbmp
    Alias /error/ "/var/www/web5/web/error/"
    ErrorDocument 400 /error/invalidSyntax.html
    ErrorDocument 401 /error/authorizationRequired.html
    ErrorDocument 403 /error/forbidden.html
    ErrorDocument 404 /error/fileNotFound.html
    ErrorDocument 405 /error/methodNotAllowed.html
    ErrorDocument 500 /error/internalServerError.html
    ErrorDocument 503 /error/overloaded.html
    AliasMatch ^/~([^/]+)(/(.*))? /var/www/web5/user/$1/web/$3
    AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web5/user/$1/web/$3
    </VirtualHost>
     
  6. falko

    falko Super Moderator ISPConfig Developer

    Looks ok. Do you see any errors in Apache's error log when you try to access an shtml page?
     
  7. bwrob

    bwrob New Member

    Same with me.
    After upgrade ssl is not working, 2.2.7 now.
    I had to copy my ssl 2.1.2 cert to /ispconfig/httpd/conf then is working fine.

    Suse9.3

    bob
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    The SSL certificates where created on the info you enter during update. Only if you enter incorrect information, your certificate is broken. But, how is this related to the SSI problem of this thread (SSI = Server Sides Includes)?
     
  9. makone

    makone New Member

    Hi - I can't find any kind of error in the httpd logs, but if I add "XbitHack On" in the ISPConfig Directives, I get:

    "mod_include: Options +Includes (or IncludesNoExec) wasn't set, INCLUDES filter removed"

    in the error log when trying to load a test.shtml or test.html (with ssi) page (both with proper permissions set).

    Would this have anything to do with the web home directory chosen when installing ISPConfig in advanced mode? I selected advanced install mode, but it never asked me for a web home directory location. I am using /var/www and set this via the ISPconfig interface, not via the install app. But everything else seams to work on this ISPconfig web server, including php, SSL, perl, mail, etc.

    I have been using the shared IP folder for the website that needs ssi, and that seems to have been a workaround for now, but I have never before seen this behaviour with ISPconfig.
     
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Please correct the path in the following directives in your httpd.conf / apache.conf to match your homedir:

     
  11. makone

    makone New Member

    Fixed!

    That worked, of course. Thanks! I should have caught this. Duh.

    Although my original httpd.conf directory entries were a little different - I have been looking at these entries for a while now, thinking that this looked weird:

    <Directory /*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /*/user/*/web>
    Options +Includes
    AllowOverride Options
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>
     
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    In which directory are your websites located?
     
  13. makone

    makone New Member

    Websites are in /var/www/
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, then the directoyr entries must look like this:

    <Directory /var/www/*/web>
    Options +Includes -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /var/www/*/user/*/web>
    Options +Includes
    AllowOverride Options
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>

    <Directory /var/www/*/cgi-bin>
    Options ExecCGI -Indexes
    AllowOverride None
    AllowOverride Indexes AuthConfig Limit FileInfo
    Order allow,deny
    Allow from all
    <Files ~ "^\.ht">
    Deny from all
    </Files>
    </Directory>
     
  15. makone

    makone New Member

    That's exactly what I did to get it to work, thanks to your help. Thanks SO MUCH for your time and effort on this.
     

Share This Page