ssh to a web directory

Discussion in 'General' started by resnostyle, Oct 18, 2006.

  1. resnostyle

    resnostyle New Member

    ok i am trying to install something on one of my websites.. the only problem is i need ssh access to the directory and cant get access. does ispconfig support this?
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Sure, ISPConfig supports this. Did you enable the shell checkbox for the website and the ISPConfig user you want to coonect with SSH?
     
  3. resnostyle

    resnostyle New Member

    ok yes i have it enabled. currently i am using a router, so when i connect to my server is use the internal address. i can connect with it this way but i get the following mesage:
    Code:
    Linux server1 2.6.12-9-386 #1 Mon Oct 10 13:14:36 BST 2005 i686 GNU/Linux
    
    The programs included with the Ubuntu system are free software;
    the exact distribution terms for each program are described in the
    individual files in /usr/share/doc/*/copyright.
    
    Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
    applicable law.
    No mail.
    Last login: Tue Oct 17 23:49:10 2006 from 192.168.1.X
    
    and then it logs back out... i get this same problem outside my network.
     
    Last edited: Oct 19, 2006
  4. falko

    falko Super Moderator ISPConfig Developer

    With what username are you trying to connect? What's the output of
    Code:
    grep [I]username[/I] /etc/passwd
    ? Any errors on /var/log/auth.log?
     
  5. resnostyle

    resnostyle New Member

    where do you want me to enter that command? because the system logs me out...
     
  6. resnostyle

    resnostyle New Member

    when i entered
    Code:
     grep username /etc/passwd 
    i got
    Code:
    web18_username:x:10002:10018:name:/var/www/web18:/bin/false
    
     
  7. falko

    falko Super Moderator ISPConfig Developer

    You must replace username in
    Code:
    grep [I]username[/I] /etc/passwd
    with the real username you use to log in.
     
  8. resnostyle

    resnostyle New Member

    that is what i got other than the "username" i changed it for security reasons.
     
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Please double check that you enabled shell in the website settings AND the settings of the user you try to login. You will have to enable it in 2 places!

    If you enabled it correctly, the shell in /etc/passwd will change from /bin/false to /bin/bash.
     
  10. resnostyle

    resnostyle New Member

    i dont think thats the problem because this account is under the admin. but where can i check to make sure this client has thhose privalages?

    i cant seem to find it?
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    It does not matter if an account is admin or not. The only relevant setting are the shell checkboxes. I'am one of the core developers and I know what I'am talking about!
     
  12. resnostyle

    resnostyle New Member

    ok so i can only find one shell checkbox. where do i find the other? i believe thats the one im missing...
     
  13. resnostyle

    resnostyle New Member

    thanks till! i found the problem.

    by the way, i wasnt challenging you. i had never seen another check box somewhere else.

    nice program, how long did it take to code?
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig is under development for 3 - 4 years now. If I remember correctly.
     

Share This Page