ssh php issue

Discussion in 'ISPConfig 3 Priority Support' started by kwickcut, Feb 4, 2018.

  1. kwickcut

    kwickcut Member

    i am trying to setup a cron and run it. the issue is the site runs on php7.0 and shell runs PHP 5.3.29

    when i try to run the command
    Code:
    php bin/magento cron:install [--force]
    i the following error
    Code:
    Parse error: syntax error, unexpected '[', expecting ')' in /var/www/clients/client1/web2/web/bin/magento on line 21
    i have looked and have not found a way to change the shell to php7.0 how can i make this change


    thanks

    kwick
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Just use the php 7 binary instead of the php 5 binary. So isntead of:

    php bin/magento cron:install [--force]

    you use something like

    /path/to/my/php7bin/php bin/magento cron:install [--force]
     

Share This Page