SSH access for clients

Discussion in 'Installation/Configuration' started by wpwood3, Oct 13, 2007.

  1. wpwood3

    wpwood3 New Member

    How to I allow clients to access the sites they manage via SSH?

    I have set up clients and websites in ISPConfig. All looks well there. They can login to ISPConfig and can use FTP. They all show up if I run:
    getent passwd
    Is there something additional I need to do in CentOS to give clients access via SSH?
  2. edge

    edge Active Member Moderator

    Did you enable "Shell Access:" for the site?
    It's in ISPconfig > site > Basis

    You might also like to "chroot" the users.
  3. wpwood3

    wpwood3 New Member

    Yes, I had already done that. Still no SSH access...

    Any other ideas?

    Attached Files:

  4. mlz

    mlz New Member

    I know this sounds stupid, but you've installed openssh and have it running, right?
  5. wpwood3

    wpwood3 New Member

    When I try to access a site via SSH as a client I get this error:

    File transfer server could not be started or it exited unexpectedly.
    Exit value 1 was returned. Most likely the sftp-server is not in the path of the user on the server side.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    What you are trying to do is to use sftp and not SSH. Try to use a SSH client like putty to connect to your SSH server.

    For sftp, have a look at your sshd config file and make sure that sftp is installed and enabled.
  7. wpwood3

    wpwood3 New Member

    I thought SSH and SFTP were the same thing.

    Regardless, I've always used SSH Secure Shell 3.2.9 and I assume that uses SSH. I have no problem connecting and transferring files as root but none of my clients can login.

    My sshd_config contains the following line:
    Subsystem sftp /usr/libexec/openssh/sftp-server

    I downloaded and installed Putty but still got exactly the same result. Only root can login.

    This server is a test server sitting right next to me. I cannot login to the console using any of the client usernames/passwords that were created in ISPConfig.
  8. wpwood3

    wpwood3 New Member

    Progress but no solution

    I think I'm starting to understand the problem but, I don't know why it is happening.

    If I look at the clients in my /etc/passwd file they look like this:
    The "/bin/false" is preventing them from being able to login and receive a Bash prompt. I would assume that checking the "Shell Access" box in ISPConfig would change "/bin/false" to "/bin/bash" but it didn't!

  9. wpwood3

    wpwood3 New Member

    Problem solved

    :eek: I'm an idiot! Please kick me... :eek:

    I had shell access turned ON for the SITES but NOT for my clients. Doh...

    After looking at the results in the passwd file I went back and looked at each client in ISPConfig. Sure enough, the little boxes that say "Shell Access" were not checked. When I originally setup each site I did not check shell access for any site or users. It was only after I enabled shell access for the sites that I started testing if the users could login.

    ...I'll go back to my room now.
  10. alfonso

    alfonso New Member

    Not working for me

    Which way did you enable access for clients? I only see the Shell access option on the site tab.

    Thank you.
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    Clients can nevre login to your server by SSH or FTP as they are no linux users. Only the users of the websites can login to your server by SSH or FTP if you enabled it in the site settings.
  12. alfonso

    alfonso New Member

    SSH Access

    It accept the user and password, but is defined as /bin/false so it get me out after MOTD.

    I have checked Shell access correctly on properties, but still cannot login.

    Any idea?

    Thank you.
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Which ISPConfig version do you use? The ISPConfig dev versions have a additional checkbox for shell access in the user settings that must be anabled.
  14. alfonso

    alfonso New Member


    I am using the 2.2.18 last release.
  15. falko

    falko Super Moderator ISPConfig Developer

    I think in 2.2.18, you must enable Shell access as well for each user (under User & Email).
  16. xrat

    xrat Member

    Hint: If falko thinks it means you can be sure it actually is the case ;)
  17. falko

    falko Super Moderator ISPConfig Developer

    I've just verified it, and it is like I guessed. :)

Share This Page