SRV records behaving strangely

Discussion in 'General' started by MrM, Oct 14, 2009.

  1. MrM

    MrM New Member


    I have created a SRV record with the following values:
    Hostname      : _xmpp-server._tcp
    Server Record : 5 0 5269
    TTL           : 60
    If I then "dig" this record, I get the following result:

    $ dig _xmpp-server._tcp.mydomain.tld IN ANY @my.nameserver.tld
    [I]-- snip --[/I]
    _xmpp-server._tcp.mydomain.tld. 86400 IN	SRV	0 5 0 5269\
    The TTL seems to have been ignored, and also the record itself has changed. Is this normal, or is ispconfig messing something up? I have no experience with SRV records, this is the first time I'm setting one up.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Look in the mysql database. If the server record is stored there as you entered it in ispconfig, then it is not related to ispconfig.
  3. MrM

    MrM New Member

    In the dns_rr table, the record appears fine.

    So, is this a problem, what dig displays, or will the record work as intended? I don't know how else to test it, except with dig.
  4. MrM

    MrM New Member

    I think I've figured out what the problem is.

    I've been tempering with the database record, and found out that dig gives the correct response if I change the data field to "5 0 5269" (without the quotes) and the aux field to 5. When I do this, I get
    _xmpp-server._tcp.mydomain.tld. 86400 IN	SRV	5 0 5269
    So it seems, the problem is related to ispconfig after all. Apparently, ispconfig should allow me to set a priority (the aux field) on SRV records, but it does not.

Share This Page