Squirremail language

Discussion in 'ISPConfig 3 Priority Support' started by muekno, May 15, 2016.

  1. muekno

    muekno Member HowtoForge Supporter

    On my SuSe 13.2 server the user language preference for german works.
    On my new Mailserver debian jessie latest patches, selecting german only works for help text.
    Any hint?

  2. muekno

    muekno Member HowtoForge Supporter

    additional question, will it be possible to install roundcube parallel to squirrelmail. To implement a password change by user, what would be better squirrelmail or roundcube.

  3. muekno

    muekno Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to run:

    dpkg-reconfigure locales

    and ensure that the de_* locales are selected.


    I did not had that problem yet. Ensure that you access the right SOAP url ( /remote/ sub folder of the ispconfig URL).
    muekno likes this.
  5. muekno

    muekno Member HowtoForge Supporter

    Thank you.
    Language in squirrelmail, now working, parallel install of roundcube too.
    "Ensure that you access the right SOAP url ( /remote/ sub folder of the ispconfig URL)." Can you
    concretize this.
    My ispconfig3_account/config/config.inc.php looks like
    $rcmail_config['identity_limit'] = false;
    $rcmail_config['remote_soap_user'] = 'roundcube';
    $rcmail_config['remote_soap_pass'] = '********';
    $rcmail_config['soap_url'] = 'http://admin.gerdakloos.de:8080/remote/';
    It is a multiserver system with separate ISPConfig admin server, as I understood the installation of the plug should be on the mail server where postfix, dovecot and roundcube are installed.
    If I do not use ssl, I thnk I can skip the cerificate installation.

  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The plugin is part of roundcube, so you have to install it on th server wher roundcube is installed. the SOAP URL looks fine (if the URL is your ISPConfig master server).


    If I open http://admin.gerdakloos.de:8080/ then I get a 400 bad request error, so there must be something wrong with that URL. http://admin.gerdakloos.de:8080/ should bring up your ispconfig login and http://admin.gerdakloos.de:8080/remote/ should return just a white page (without an error).
  7. muekno

    muekno Member HowtoForge Supporter

    "I do not use SSL" perhaps leads wrong. I mend internally, but yes even itern teh server does not
    The Admin Page is secured by https. So https://admin.gerdakloos.de:8080 works, https://admin.gerdakloos.de:8080/remote brings up a blank page without error. https://smtp1.gerdakloos.de/mail brigs me to roundcube. Both Servers have valid official cerificated from startcomssl. I have changed the line in ispconfig3_account/config/config.inc.php to https//..
    Now going I got the message "Soap Error: Could not connect to host"

    Both servers, multiserver setup as described in the manual, are on a private net
    behind a firewall. External access via NAT. Internet itself has mask, so each server has ist own external an internal address. Ping to admin.gerdakloos.de rom the console of smtp1.gerdakloos.de resolves in the internal address. I think/hope roudcube plugin will not resolve the external address. /etc/hosts on every server in the multiserver enviorement have all other servers internal (and only internal) addresses listet. All other communication, especially sql, between the servers works. Even openssl_ s_client -connect admin.gerdakloos.de_8080 from console of smtp1 works

    Any way to debug

  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so you use https as the remote api connects in the same way that you connect with your browser. Use the same URL plus "/remote/" for the API that you use for the normal browser connections. And I'm not sure if startssl is recognized by PHP as valid SSL authority, so you should add their ssl cert in the way that is described in the tutorial.
  9. muekno

    muekno Member HowtoForge Supporter

    I think I have implemented the startssl certificates well, that means, beside the server .crt and .key files also the cain certificates too. In ispconfig-vhost on the admin server SSLCerificateFile, SSLCertificateKeyFile, and SSLCACerificateFile points to the correct Key, cert and CA bundle. Apache starts without errors.
    # SSLCertificateFile /usr/local/ispconfig/interface/ssl/ispserver.crt
    SSLCertificateFile /etc/ssl/certs/admin.gerdakloos.de.crt
    # SSLCertificateKeyFile /usr/local/ispconfig/interface/ssl/ispserver.key
    SSLCertificateKeyFile /etc/ssl/private/admin.gerdakloos.de.key
    # #SSLCACertificateFile /usr/local/ispconfig/interface/ssl/ispserver.bundle
    SSLCACertificateFile /etc/ssl/certs/startssl_root_bundle.crt

    on admin server /etc/php5/apache2/php.ini I added
    and restarted apache
    Still the sam error!!
    By the way admin server ist still an opensuse 13.2, is there an easy or even not easy way to move it to debian jessy.


    Last edited: May 18, 2016
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to access the remote URL from mail server with a command line browser like lynx or wget, do you get an error?

    Yes, thats possible. But a bit of manual work as you have to install a new server incl. ispconfig as standalone server and then move over the dbispconfig database and mysql users to the new server.
  11. muekno

    muekno Member HowtoForge Supporter

    in my eyes that looks fine
    [email protected]:~# wget https://admin.gerdakloos.de:8080/remote/
    converted 'https://admin.gerdakloos.de:8080/remote/' (ANSI_X3.4-1968) -> 'https://admin.gerdakloos.de:8080/remote/' (UTF-8)
    --2016-05-18 12:20:24-- https://admin.gerdakloos.de:8080/remote/
    Resolving admin.gerdakloos.de (admin.gerdakloos.de)...
    Connecting to admin.gerdakloos.de (admin.gerdakloos.de)||:8080... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 0 [text/html]
    Saving to: 'index.html'

    index.html [ <=> ] 0 --.-KB/s in 0s

    2016-05-18 12:20:24 (0.00 B/s) - 'index.html' saved [0/0]

    But from Roundcube still "Soap Error: Could not connect to host"

    Any other things I can try?

  12. muekno

    muekno Member HowtoForge Supporter

    have troubles moving admin server
    Did a dump of dbispconfig and user table from mysql
    save the ispconfig db password from config.inc.php
    Shut down admin server,
    installed a new stand alone admin server. same name same address
    Added "use mysql;" and "drop user;" to the dump of user.sql,
    both dadatbasese
    changed the password
    restored both to knew server
    restarted apache and mysql
    get the ispconfig login page
    but trying login I still remain in login page
    Any hint, idea

    Thanks Rainer
  13. muekno

    muekno Member HowtoForge Supporter

    Works now, took another browser (safari) may the problem was chrom, having a problem with the self signed certificate


    P.S. sorry seams to work, can login into new admin server, all show information seams correct, but
    database seam not to be updated from slaves, so admin say some servers need updates, dis the updates but the new information ist not shown in monitor, add a test dns A record, job queue fills up with
    2016-05-20 06:28 ns1.gerdakloos.de Update dns_rr

    one server was on p8 I did an update to p9, Monitor does not show it.
    checked sql connection from slaves to master, works fine can conncet from each slave host to admin server
    with mysql -u root -p -h admin _host
    Need help hint urgent

    Services on slave run fine

    Last edited: May 20, 2016
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    It takes some time until the new version shows up.
  15. muekno

    muekno Member HowtoForge Supporter

    I know, but it is now more than 3 hours, adding DNS A record is still int he queue, the ISPConfig update was half an hour earlyer, updateting deian servers too, the ISPConfig version still a p8, two other debian servers I did an software update this morning monitor did not jet recognize. espcially adding an A record need only some minutes. Did I forgot something by moving admin server from suse to debian, as described above.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    There is most likely a mysql connection problem hen the queue does not get processed. Try to connect from slave to master with mysql command by using the exact master connection details from /usr/local/ispconfig/server/lib/config.inc.php of the slave. example:

    mysql -h master.server.tld -u ispcsrv2 -p dbispconfig

    then enter the password when requested by the command.
  17. muekno

    muekno Member HowtoForge Supporter

    Ok seams to the problem, the msyql/user table has all records for the slave with name isp...x and correct IPs hostnames, should be as I copied the table. so what can be wrong, maybe the password (should not as nothing changed on the clients and problem exists on all clients)
    I would like to set the password new in user table, but there is a hash. I know phpmyadmin cat hash the password, but I need to known the hash algorithm MD5 or or

    What else could be gone wrong in the move?


    Please help, it is uregent. Thank you
    Last edited: May 20, 2016
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    The most likely reason are wrong hosts files, ensure that all hosts of all nodes are listed in all hosts files and that the IP addresses for these hosts in mysql match the ones from the hosts files.
  19. muekno

    muekno Member HowtoForge Supporter

    host files are correct, there was no reason to change, as I wrote I checked them to match with the mysql/user table, which should be correct as it was created by dump on old master and restore on nee master. The done actions are written above. communication should not be a problem, as I can proberly connect with "mysql -uroot -p -h admin.gerdakloos.de " but I got access erro with " mysql -uispcrvX -p -h admin.gerdakloos.de dbispconfig " where X is the respective number from /usr/local/ispconfig/server/lib/config.inc.php, password taken from there.


    sample error ERROR 1045 (28000): Access denied for user 'ispcrv6'@'http.gerdakloos.de' (using password: YES)

    are the any log files or can I let create some?
  20. till

    till Super Moderator Staff Member ISPConfig Developer

    Your issue is a MySQL auth issue and not an ispconfig issue, ispconfig will work again when mysql connections for the ispcsrv users are working again. Please see mysql documentation on how to enabe logging in mysql.

Share This Page