Squirremail - domain.tld/webmail not working

Discussion in 'Installation/Configuration' started by sellotape, Jul 31, 2011.

  1. sellotape

    sellotape New Member

    Hi there.

    I have a uBuntu 11.04 Server setup using ISPConfig.

    I followed the perfect server guide on here to the letter however I am unable to access my webmail client (squirrelmail) remotely.

    http://somedomain.tld/webmail does not give me a 40* message but instead attempts to download Squirrelmail's 'index' file.


    At first I thought this might be permissions however after changing the group and user to www-data and 755 - it's still not working!


    Has anyone else had a similar issue or does anyone know how I might be able to fix this!


    Many thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you enable PHP for this web site?
     
  3. sellotape

    sellotape New Member

    Hi there Falko.

    Fast-CGI is currently enabled - is this correct?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Try mod_php.
     
  5. sellotape

    sellotape New Member

    Thanks Falko.

    I've tried that and now have an Internal Server Error 500.

    As far as I know the permissions are all set okay and I can still access Squirrelmail by accessing it via my IP or locally on the network.
     
  6. mentes

    mentes Member

    The configuration for squirrelmail is not the same as sites configuration. I had a similar problem with roundcube and I solved it disabling SuPHP.

    a2dismod suphp
    /etc/init.d/apache2 restart


    Can you paste here /etc/apache2/conf.d/squirrelmail.conf ?
     
  7. sellotape

    sellotape New Member

    Hi Mentes, thank you for your reply.

    Here is a copy of my squirrelmail.conf file...

    Code:
    Alias /squirrelmail /usr/share/squirrelmail
    Alias /webmail /usr/share/squirrelmail
    
    <Directory /usr/share/squirrelmail>
      Options FollowSymLinks
      <IfModule mod_php5.c>
        php_flag register_globals off
      </IfModule>
      <IfModule mod_dir.c>
        DirectoryIndex index.php
      </IfModule>
    
      # access to configtest is limited by default to prevent information leak
      <Files configtest.php>
        order deny,allow
        deny from all
        allow from 127.0.0.1
      </Files>
    </Directory>
    
    # users will prefer a simple URL like http://webmail.example.com
    #<VirtualHost 1.2.3.4>
    #  DocumentRoot /usr/share/squirrelmail
    #  ServerName webmail.example.com
    #</VirtualHost>
    
    # redirect to https when available (thanks [email protected])
    #
    #  Note: There are multiple ways to do this, and which one is suitable for
    #  your site's configuration depends. Consult the apache documentation if
    #  you're unsure, as this example might not work everywhere.
    #
    #<IfModule mod_rewrite.c>
    #  <IfModule mod_ssl.c>
    #    <Location /squirrelmail>
    #      RewriteEngine on
    #      RewriteCond %{HTTPS} !^on$ [NC]
    #      RewriteRule . https://%{HTTP_HOST}%{REQUEST_URI}  [L]
    #    </Location>
    #  </IfModule>
    #</IfModule>
     
  8. mentes

    mentes Member

  9. sellotape

    sellotape New Member

    Hello.

    I did yes, no joy unfortunately.
     
  10. xciso

    xciso Member

    I have the same problem.
    Anyone know if roundcube works better?
     
  11. falko

    falko Super Moderator ISPConfig Developer

    Any errors in Apache's error log when you get the 500 server error?
     

Share This Page