squirrelmail with virtual email accounts

Discussion in 'Server Operation' started by tkaman2, Nov 21, 2007.

  1. tkaman2

    tkaman2 New Member

    Hi, I configured postfix and courier to use MySQL for delivering email to various users on various domains that I am hosting. Now I am trying to configure squirrelmail to allow login to these virtual email accounts. Is that possible with squirrel mail? When I try to log in with one of my virtual email accounts it says username or password is incorrect. Thanks

    Also, I am having trouble connecting to my mail server via an email client like outlook or evolution email... I followed the tutorial at:
    http://www.howtoforge.org/virtual-users-and-domains-postfix-courier-mysql-fedora8
    and it seems to be working... I can at least receive emails. I used sendmail to email another of my accounts and that worked fine. If anyone has any ideas why I can't connect to my mail server with an email application I would greatly appreciate hearing them. I have tried to connect via pop3 and imap. I believe I set up pop3 yesterday. I am running Fedora 8 on x86_64 platform. Thanks again for the help
     
    Last edited: Nov 21, 2007
  2. falko

    falko Super Moderator ISPConfig Developer

    Should work with Squirrelmail.

    Are there any errors in your mail log?
     
  3. tkaman2

    tkaman2 New Member

    I will email you my maillog. Its not too big. I did see some entries from dovecot. I think I accidentally installed it when I clicked a link to another tutorial and I got off track. I uninstalled dovecot and still have issues. squirrelmail says: Error connecting to IMAP server: localhost.
    111 : Connection refused. I have changed the server settings in squirrelmail's configure script to my domain name. I run the squirrelmail configtest and it outputs the following:

    This script will try to check some aspects of your SquirrelMail configuration and point you to errors whereever it can find them. You need to go run conf.pl in the config/ directory first before you run this script.

    SquirrelMail version: 1.4.11-2.fc8
    Config file version: 1.4.0
    Config file last modified: 12 November 2007 05:01:46


    Checking PHP configuration...
    PHP version 5.2.4 OK.
    display_errors:
    error_reporting: 6143
    variables_order OK: EGPCS.
    PHP extensions OK.
    Checking paths...
    Data dir OK.
    Attachment dir OK.
    Plugins OK.
    Themes OK.
    Default language OK.
    Base URL detected as: [my domain name]/webmail/src (location base autodetected)
    Checking outgoing mail service....
    sendmail OK
    Checking IMAP service....

    ERROR: Error connecting to IMAP server "localhost:143".Server error: (111) Connection refused

    I am not able to send mail from my machine (at least to hotmail) with sendmail. I was able to send email to one of my virtual email accounts from my machine though. That may be because its considered local delivery or something...I'm not sure. I was also able to email my work email account yesterday. So outgoing email is working somewhat. I do receive email at all of my virtual hosts so that part is working good. incoming mail goes to /home/vmail/[domain name]/[alias]/new.

    If you have any ideas of what is wrong I would really appreciate any help. Thanks!

    Dave
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    netstat -tap
    ? Did you start Courier after you uninstalled Dovecot?
     
  5. MisterVlad

    MisterVlad New Member

    I had this same issue (or at least similar). With the virtual users, there are a lot of different areas where you have to put in your username and password for mysql, and I endedup misspelling one of the usernames. It took me a while to find it, but after a few hours (over a few days) of searching, and re-doing the install (just the file modification parts) I finally found it in the last part... which i didn't check the previous 12 times i rechecked all the steps.

    This was the tutorial for Debian 4.0 ETCH, which may be a little different, but all in all, go over ALL files that get changed, and check for any spelling mistakes at all!

    Mistervlad.
     
  6. tkaman2

    tkaman2 New Member

    I verified some configuration settings and restarted courier (it may not have been running as you suggested) and I am able to connect now. thanks! Now I have to figure out why squirrelmail isn't letting me create folders :)

    Dave
     

Share This Page