Squirrelmail reply email address is wrong

Discussion in 'General' started by LazyEyes, Mar 13, 2009.

  1. LazyEyes

    LazyEyes New Member

    Hey guys,

    Starting to use the Squirrelmail webmail interface and found out after composing a new message and sending it out, the recipient sees the wrong reply email. Both the username and domain names are not correct

    Example
    Real Name Lazy
    Username web5_lazyeyes
    Email lazyeyes [@domain.com]

    The reply address shows web5_lazyeyes@domain.com and the domain is the hosting address and not my site's domain.

    Checking the /etc/postfix/virtusertable both web5_lazyeyes@domain.com and lazyeyes@domain.com with the alias web5_lazyeyes. And the account receives emails from both email address.

    How do i fix the reply email problems, help guys. Thanks!

    Installation Info
    ISPConfig 2
    Centos 4
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You have to set the reply address under options in squirrelmail.
     
  3. LazyEyes

    LazyEyes New Member

    So it's not a bug? Was hoping there was a more elegant solution :)
     
  4. id10t

    id10t Member

    Well, it doesn't break anything... to make it harder to "fix" though is that the webmail package installed depends on your preferences... and once said webmail package is installed, each one sets preferences in a different location, so all existing users would need to be changed and then each new user as it is added... may be easier to write a few quick fixit scripts, although it would be great if the creators for the ispconfig packages would just modify the script that creates initial settings on first login.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    There is no such script in ispconfig.
     
  6. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    You could install the New User Wizard Plugin from the SquirrelMail Homepage

    User then have to add the correct Emailaddress to proceed.

    (Well they still can put in a wrong one but at least they are redirected to the settings page.)
     
  7. id10t

    id10t Member

    I realize that... I was speaking of the people that create/maintain the webmail packages for ISPConfig to use - roundcube, uebiamail, etc. Since these packages are meant to be used in ISPConfig it would make sense to fix it there since it is a known issue when these packages are used with ispconfig...

    So not in ispconfig, not in the packages supplied by the original authors, not the debian packages, etc. just the .pkg files that are specific to being used in/with ispconfig
     

Share This Page