Squirrelmail Postfix dovecot cant emails stopped working from new user?

Discussion in 'Installation/Configuration' started by JakeTheDog, Sep 7, 2017.

  1. JakeTheDog

    JakeTheDog New Member

    Hi,

    I've been trying to setup squirrelmail on my VPS with dovecot and postfix for the past 2days now. Today I managed to get it working finally and was able to both send and recieve emails to my account. All seemed well so I created a new account for my collegue as I had only setup the webmaster account thus far. I tried logging into his account on squirrelmail to test it but had problems from the start. I've been trying to resolve the issue for a few hours and decided to try logging into my account now... Now I am unable to get my account to work both of them displaying the same error message after logging in with the correct login details... Please can anyone suggest what could be going wrong?

    It's running turnkey lamp which is a basically just using debian as its distro...

    ISPCONFIG:
    #pastebin.com/xmWHH2wA

    I've already portforwarded the ports required as you can see... It's weird because it worked fine until I added a new user...?

    Mail.log
    #pastebin.com/8N4Sh8sj

    Any help is very appreciated!
    Thanks
     
  2. Jesse Norell

    Jesse Norell Well-Known Member

    You are logging in as 'barry' but should likely be using the full '[email protected]' as your username. Dovecot should run as the vmail user and would have permission to create an INBOX under /var/vmail/domain.tld/barry but not under /var/mail/barry, which is probably what it's trying to do (I'm guessing there is a 'barry' system user in /etc/passwd with the same password? you need to create your email users in ispconfig under Email > Email Mailbox).
     
  3. JakeTheDog

    JakeTheDog New Member


    Logging in as [email protected] domain. tld (using correct name and top level domain extension ofc) does not work however just the user names does. This is for both webmaster and barry...

    Prior to adding barry as a user, webmaster was able to login, send and receive emails no problem so I feel like the issue is elsewhere?

    Also it was not setup using ispconfig so I'm not sure how to do that... I manually installed squirrelmail and dovecot following tutorials, postfix came pre-installed with the turnkey lamp install however I did reconfigure it in order to get it working in the first place. As I said, it took a lot of work to get it working but it did work with webmaster. This is when I made a new user account called barry and it all stopped working...

    You suggested maybe something about dovecot running as the vmail user, could you be a little bit more specific? would this be the issue if it had worked prior? Do you know why this could be causing the issue and can you please explain what I need to do in order to try rectify this?

    Thank you so much for all your help thus far!
    Regards
     
  4. Jesse Norell

    Jesse Norell Well-Known Member

    Should be just the opposite. There is a 'Allow custom login name' setting in ispconfig main config, do you have that enabled? (I've never used it offhand, but curious if it might let you change your username format ?)

    Do you mean logging in with [email protected] worked, or just as 'webmaster'? You added barry in ispconfig, not as a system user?

    You could post your dovecot config (ispconfig will use the single file /etc/dovecot/dovecot.conf, not everything under /etc/dovecot/conf.d/), and/or try running update.php from ispconfig install source and let it reconfigure services

    At this point it's really "who knows" if you weren't able to use a Perfect Server guide and had to do a lot of work to get it going. If you run into much time on this, is scrapping the system and starting over clean an option? Following a Perfect Server guide should have you up and running in not too much time, without all the troubleshooting/guesswork.
     
  5. JakeTheDog

    JakeTheDog New Member

    I'm not using ISPconfig?...
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so you're posting in the wrong forum. This Forum is about ISPConfig 3 only. I'll move your thread to the general Linux forum.
     
    JakeTheDog likes this.
  7. JakeTheDog

    JakeTheDog New Member

    Ah I was not aware of this my bad! I actually searched squirrelmail so I could use the same forum as someone with similar problems but didn't realise it was ISPconfig and thats unrelated! Apologies
     
  8. Jesse Norell

    Jesse Norell Well-Known Member

    heh .. sorry, I didn't really read your first paste, which says clearly at the bottom, 'No ISPConfig found'. :)

    The answers are quite different then, and I'm a little less comfortable responding, but right offhand you may have a permissions problem, as that 'Error: Failed to autocreate mailbox INBOX: Permission denied' sure stands out.
     

Share This Page