Squirrelmail Package!

Discussion in 'Tips/Tricks/Mods' started by bkrausz, Jun 16, 2006.

  1. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

    Thanks Brian!
     
  2. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    Why !! Why !!!!

    Why did you remove the language option?!?!!? i need it on spanish ! :eek:
     
  3. torusturtle

    torusturtle ISPConfig Developer ISPConfig Developer

  4. tom

    tom Member

    Does that Squirrelmail package work on php5?
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    The squirrelmail package is installed on the ISPConfig httpd on port 81 and there is always a php 5.1 installed, so i guess it works with PHP5.
     
  6. ikaros

    ikaros New Member

  7. falko

    falko Super Moderator ISPConfig Developer

    It depends on in which folder you installed Squirrelmail. You can use an FTP client or WinSCP to browse your folders to find out where it is installed.
     
  8. ikaros

    ikaros New Member

    It's installed in /home/admispconfig/ispconfig/web/squirrelmail but how does this help me?
     
    Last edited: Sep 28, 2006
  9. falko

    falko Super Moderator ISPConfig Developer

    Then it's installed within ISPConfig's web space, and you must use something like http(s)://example.com:81/squirrelmail/
     
  10. tom

    tom Member

    Error:

    I can't create an new folder whithin SquirrelMail whithout creating it as subfolder in INBOX. I've tried to create an new folder beside to INBOX called SPAMBOX but always I ge this error:


    What's wrong?
     
  11. ikaros

    ikaros New Member


    yeap, https://www.example.com:81/squirrelmail did the trick. Thanx!
     
  12. falko

    falko Super Moderator ISPConfig Developer

    What's in your mail log?
     
  13. bosei

    bosei New Member

    STEP 3. link it to sites-enabled:
    Code:
    ln -s /etc/apache2/sites-available/webmail.conf /etc/apache2/sites-enabled/webmail.conf

    This seems to be self referencing. What are we linking to what. Can the same thing be achieved by including webmail.conf in httpd.conf?
     
  14. falko

    falko Super Moderator ISPConfig Developer

    No, it isn't. You're linking /etc/apache2/sites-enabled/webmail.conf to /etc/apache2/sites-available/webmail.conf.

    Yes.
     
  15. bosei

    bosei New Member

    Thanks Falco. On a quick read i missed the difference completely.
    :rolleyes:
     
  16. actionplant

    actionplant New Member

    I installed in this fashion following the Perfect Setup Ubuntu 6.06 install. I installed the latest stable release of ISPConfig two days ago, then this Squirrelmail package. I set up websites, and under ISP Site in the User & Email tab created a new mail user for each domain.

    I can get to the Squirrelmail login page for each domain, but after submitting with the email address and password (as configured for user web1_user, web2_user, etc as created in ISPConfig) I get the following error:

    I've noticed that even though I set up ISPConfig according to the install manual on their site, supposedly configured to go to http://odin.trekbeyond.org:81 I can get there with or without the "odin" subdomain, ie http://trekbeyond.org:81 also works. When I log into Squirrelmail, for one domain the first redirect is to http://odin.trekbeyond.org:81/squirrelmail/src/redirect.php, but for another domain the redirect is to http://trekbeyond.org:81/squirrelmail/src/redirect.php but it doesn't seem to make a difference, I keep getting the same error. Any ideas?

    What am I missing? Under Server Settings in ISPConfig the server name is odin, the Hostname is odin, and the domain is trekbeyond.org. So why is this happening?
     
    Last edited: Nov 30, 2006
  17. falko

    falko Super Moderator ISPConfig Developer

    You must send an email first to that user. Maildir is created when the first email arrives for that user.
     
  18. actionplant

    actionplant New Member

    Thanks falko, that worked.

    And helped me discover a different problem. The email came through just fine, but when I responded, instead of showing up in the destination mailbox as being from the address I set up, which was [email protected] (heh, don't ask) it came from [email protected]

    Which is weird, considering the server is set up as odin.trekbeyond.org.

    What the heck?

    Edit- Oh yay! After a complete re-install (I was having issues and started over this morning from scratch so I could walk through carefully again) I got everything up and running. The server sent one single email, and promptly crashed. Oh well, I guess that's further than I got yesterday. ;)
     
    Last edited: Dec 1, 2006
  19. LumpyOne

    LumpyOne New Member

    Just wanted to say thanks for making this so easy to install! Happy happy joy joy. :)

    FYI, to make it easy for clients, I simply set up a page at www.example.com/mail for my clients, so that they could click to get to the secure URL for squirrelmail. It's an extra click, but easy to set up and my clients like it just fine.
     
  20. falko

    falko Super Moderator ISPConfig Developer

Share This Page