SquirrelMail on IspConfig: Can't send

Discussion in 'Installation/Configuration' started by ai_77, Feb 23, 2007.

  1. ai_77

    ai_77 New Member

    I recently installed squirrel mail on my server that is running IspConfig. For some reason I am able to recieve emails but none of the messages I send are ever recieved. Ispconfig is using Postfix and the server is on an Ubuntu distro. I am using sendmail in SquirrelMail and when I run the configtest.php script it says that everything is working fine, but the problem still persisits.

    running telnet localhost says 220 domain.com ESMTP Postfix (Ubuntu)
    I have a /etc directory but no /etc/hosts directory.

    Does anyone have any ideas on how to fix this? Thanks
     
  2. till

    till Super Moderator

    Please post an excerpt of your mail logfile.
     
  3. ai_77

    ai_77 New Member

    maillog

    It may help to say that I have recently moved the server from the old office which had cable to the new one which is using dsl. Also the server is working through a smoothwall firewall on the Orange interface if that helps. Here are some results in the mail log:

    ...skipping one line
    Feb 23 11:19:40 localhost postfix/smtp[28945]: 1B4EAE70364: to=<ai_77@hotmail.co
    m>, relay=none, delay=56633, status=deferred (Host or domain name not found. Nam
    e service error for name=hotmail.com type=MX: Host not found, try again)
    Feb 23 11:19:40 localhost postfix/smtp[28947]: 74451E7038C: to=<dimitriy@antec.q
    es.net>, orig_to=<dimitriy@qualitysiding.net>, relay=none, delay=245000, status=
    deferred (Host or domain name not found. Name service error for name=antec.qes.net type=MX: Host not found, try again)
    ..and so on...

    Feb 23 11:52:40 localhost postfix/qmgr[31918]: D7D63E70350: from=<jimnicholas37@
    hotmail.com>, size=5214, nrcpt=1 (queue active)
    Feb 23 11:52:40 localhost postfix/qmgr[31918]: E8055E70235: from=<>, size=3072,
    nrcpt=1 (queue active)
    Feb 23 11:52:40 localhost postfix/qmgr[31918]: E2F4EE7035B: from=<ai_77@hotmail.
    com>, size=1253, nrcpt=1 (queue active)
    Feb 23 11:53:00 localhost postfix/smtp[30190]: B7F12E70372: to=<alex@antec.qes.n
    et>, orig_to=<alex@www.qualitysiding.net>, relay=none, delay=173000, status=defe
    rred (Host or domain name not found. Name service error for name=antec.qes.net t
    ype=MX: Host not found, try again)
    Feb 23 11:53:00 localhost postfix/smtp[30191]: B2CD0E7038A: to=<alex@antec.qes.n
    et>, orig_to=<alex@www.qualitysiding.net>, relay=none, delay=173000, status=defe
    rred (Host or domain name not found. Name service error for name=antec.qes.net t
    ype=MX: Host not found, try again)
    Feb 23 11:53:00 localhost postfix/smtp[30192]: 63231E7038F: to=<itsupport@antec.
    qes.net>, orig_to=<itsupport@qualitysiding.net>, relay=none, delay=340751, statu
    s=deferred (Host or domain name not found. Name service error for name=antec.qes.net type=MX: Host not found, try again)
    Feb 23 11:53:00 localhost postfix/smtp[30193]: 645A5E70358: to=<alex@antec.qes.n
    et>, orig_to=<alex@qualitysiding.net>, relay=none, delay=62356, status=deferred
    (Host or domain name not found. Name service error for name=antec.qes.net type=M
    X: Host not found, try again)

    What I can see from here is that there is an error for antec.qes.net. antec is my server's name. But I am not sure what the previous admin used "qes.net'" for. The current domain is "qualitysiding.net"
     
  4. till

    till Super Moderator

    Please add antec.qes.net at the end of /etc/postfix/local-host-names and restart postfix. Is antec.qes.net listed in /etc/hosts ?
     
  5. ai_77

    ai_77 New Member

    Hmm, I added antec.qes.net and it is also listed in /etc/hosts file and after restarting still no luck sending. Here is the message mail.log from the last attempt to send:

    Feb 26 13:53:58 localhost postfix/qmgr[5050]: 87355E7035D: from=<alex1@qualitysiding.net>, size=905, nrcpt=1 (queue active)
    Feb 26 13:53:58 localhost postfix/trivial-rewrite[5246]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
    Feb 26 13:54:18 localhost postfix/smtp[5247]: 87355E7035D: to=<ai_77@hotmail.com>, relay=none, delay=327330, status=deferred (Host or domain name not found. Name service error for name=hotmail.com type=MX: Host not found, try again)
     
  6. edge

    edge HowtoForge Supporter

    I think that your provider (verizon.net) is blocking port 25
     
  7. ai_77

    ai_77 New Member

    wow, it looks like your right. That would certainly explain why it worked on comcast and stopped working when I switched to verizon but can still recieve emails. I read up on it and it looks like a very dumb idea. Now I have to figure out how to work around it. Does anybody have any quick and easy (but not too expensive) solutions. I might be willing to pay a few bucks a month for a service but would rather have it work through my own server for free. I was given the smtp and pop server addresses from verizon but a quick test using them yielding no results for some reason. (I changed the smtp server simply to the one provided from verizon).
     
  8. ai_77

    ai_77 New Member

    Almost there!

    actually I found one that works pretty good: authsmtp.com. Its only like $24 for a year so I signed up and it seems to be working now. I have just one more question: On roundcube I can configure the smtp username and password but it looks like squirrelmail just uses the email account's username and password. Is there a way I could set the smtp info regardless of the user? Thanks
     
  9. till

    till Super Moderator

    If I remember correctly, there is a config file where you can define this. The ISPConfig squirrelmail is in /home/admispconfig/ispconfig/web/squirrelmail/
     

Share This Page