squirrelmail login failing

Discussion in 'Installation/Configuration' started by t-mug, Jun 13, 2007.

  1. t-mug

    t-mug New Member

    I've got a fresh ISPconfig installation here; the squirrelmail package from http://ispconfig.org/downloads.htm is installed additionally.
    But my web login via the https://domain.tld:81/squirrelmail is always failing: "Unknown user or password incorrect."
    The /var/log/mail.log says:
    Code:
    Jun 13 13:27:02 ... imapd: Connection, ip=[::ffff:127.0.0.1]
    Jun 13 13:27:02 ... imapd: LOGIN FAILED, user=web1_test@mydomain.tld, ip=[::ffff:127.0.0.1]
    Jun 13 13:27:07 ... imapd: LOGOUT, ip=[::ffff:127.0.0.1], rcvd=63, sent=332
    The login would probably work if the "user" value would be "web1_test" only (without "@mydomain.tld"), so like it does via my web client. The point is: I've put in the login username box of squirrelmail only "web1_test" as username - it seems that squirrelmail adds automatically this "@mydomain.tld" stuff. Are there any suggestions, how to solve this?

    Thanks a lot
     
  2. bitonw

    bitonw New Member

    i have the same set up as your and logon with the users real email address...

    so if you got blaname@bladomain.com as email address, you use this to logon.

    have fun,
    bt
     
  3. t-mug

    t-mug New Member

    The same

    Hi bitonw,

    thx 4 your reply; if I try to logon by "web1_test@mydomain.tld" the result is exactly the same. Squirrel checks that there's a "dom.tld" extension and does nothing in this case obviously.

    But it seems to me, for authentication I need the exact "web1_test" string as user value, since ISPconfig does not support usernames as email addresses? How come these together?

    bye & greetings
     
  4. t-mug

    t-mug New Member

    Solution

    OK, I found it out. ISPconfig maps the email address from the squirrel login form to the username expected by postfix by means of a file called /etc/postfix/virtusertable. Here, I then recognized, there was an error done by myself: I created a web as subdomain, so I had to input web1_test@[B]sub.[/B]dom.tld as username in squirrel, and the mapping file did the rest well. If I typed only the username, squirrel has completed this by the "@dom.tld" but for this there was no mapping entry in the virtualusertable und the logon failed.
    This had confused me!

    So thank you again.
     

Share This Page