Squirrelmail - login error

Discussion in 'Server Operation' started by Hans, Apr 18, 2006.

  1. Hans

    Hans Moderator

    On my Debian system with ISPConfig installed, i have installed Squirrelmail.
    I have created a website webmail.mywebhostcompany.tld and Squirrelmail is installed in this website.

    In my browser: when i point to URL http://webmail.mywebhostcompany.tld, i see Squirrelmail's login screen.

    When i try to login for the first time with a username and password, an error occurs:


    Error opening ../data/default_pref
    Could not create initial preference file!
    ../data/ should be writable by user www-data
    Please contact your system administrator and report this error.


    How can i solve this?



    Hans
     
  2. falko

    falko Super Moderator

    Can you post the output of
    Code:
    ls -la /path/to/data
    ?
     
  3. Hans

    Hans Moderator

    I do not understand, but when i do an ls -la /path/to/data

    The system replies: No such file or directory



    To install Squirrelmail i did the following:

    -I extracted Squirrelmail 1.4.6 in website http://webmail.myhostcompany.tld/
    -I did not change essential things using the Perl command conf.pl
    -I only checked if Courier was selected for IMAP.

    Are there more steps to take to get Squirrelmail working?


    Hans
     
  4. falko

    falko Super Moderator

    You must replace /path/to/data with the real path.
     
  5. Hans

    Hans Moderator

    Falko,

    I have changed that to /var/www/webmail.myhostcompany.tld/web/data
    which is Squirrelmail's data directory.

    I have tried to log in again at http://webmail.myhostcompany.tld

    Now the error occurs:

    Error opening /var/www/webmail.myhostcompany.tld/web/data/default_pref
    Could not create initial preference file!
    /var/www/webmail.myhostcompany.tld/web/data/ should be writable by user www-data
    Please contact your system administrator and report this error.

    Has this something to do with read/write access?
    And if so, how do i change this?
    Or is there something else wrong?

    I suppose that i am almost there ...

    Hans
     
  6. Hans

    Hans Moderator

    Problem solved

    Hey there!

    I want everyone to know that i do not need help about this thread anymore.

    I discovered that PHP-safemode was ON...
    After turning this OFF, i could log in.

    Hans :)
     

Share This Page