Squirrelmail Broken

Discussion in 'Installation/Configuration' started by natelabo, Apr 23, 2010.

  1. natelabo

    natelabo New Member

    I have a perfect server setup. Ubuntu 9.10...

    Squirrelmail was working fine initially. I have now added some sites and it doesn't work. I go to:
    www.example.com/webmail -> 404
    http://www.example.com/webmail ->404 (local ip of server) -> 404

    Everything else works... I did:

    apt-get remove --purge squirrelmail

    I had fles left in /usr/share/squirrelmail
    so i did
    rm -r /usr/share/squirrelmail

    Then I reinstalled according to instructions in Perfect server guide. Including creating the link. I am a complete newb to linux so I basically don't know where to look or what to do from here.
  2. CSsab

    CSsab New Member

    Configure squirrelmail

    Did you do:

    You have to tell squirrelmail to use courier as it's mail transport agent. Have another look at the how-to.
  3. natelabo

    natelabo New Member

    Yes I also did the configure setting courier. Basically I followed the install guide up to the point where it states test http://xxx.xxx.xxx.xxx/webmail and I am still getting the 404
  4. Mikegyver42

    Mikegyver42 New Member


    I have the same problem under Debian Lenny and Ispconfig3
    Squirrelmail work's fine but if i create a new web site using the IP address of the server, squirrelmail returns an error 404.
    If i modify the web site IP adress using the * squirrelmail works.

    Do you have any idea to solve the problem ?

  5. DaleHutch

    DaleHutch Member

    I have a similar problem... I created some websites in ISPconfig 3.

    Well phpadmin works fine both internal and external but squirrelmail only works internal not external.

    I've look everywhere.

  6. The-Ghost

    The-Ghost New Member

    Same problem here, it looks fine when I installed the server, but after creating domains, the webmail give's 404 error's
  7. BorderAmigos

    BorderAmigos New Member

    Make sure the symbolic link /var/www/webmail is still pointing to /user/share/squirrellmail. Also make sure that squirrellmail is still installed at same location.

    Also, www.example.com/webmail will point to the web directory not to the /var/www location. Try an A record in the DNS called mail that has the IP address then try mail.example.com/webmail.
    Last edited: May 12, 2010
  8. The-Ghost

    The-Ghost New Member

    squirrellmail is still on the same place, the symbolic link is still active.
    I tryed your suggestion to create an a record, but it doesn't work.
  9. DaleHutch

    DaleHutch Member

    I tried all that stuff too.. Still nothing but 404

    I did learn that if I put the IP address in the site's config settings the local connection to squirrelmail stops... So now both internal and external are down. Use the "*" and just internal works and extrernal is down.

    I'm running out of options here.

    phpmyadmin works fine on both, internal and external.

  10. The-Ghost

    The-Ghost New Member

    Allso when I use * in all the domains, it's still an 404 page.
    Is there anyone who have this working, I realy mis the webmail function
  11. The-Ghost

    The-Ghost New Member

    I have found a workaround.
    There are two way to acces the webmail.

    -1 put in the resolve.conf in the first line.

    -2 set all the domain's on * in the ip field and remove the ip addresses under system => server ip addresses.

    In both cases you can acces webmail by using the server hostname /webmail.

    I use the second way, in that case you can use the dns options.

  12. luigiwork

    luigiwork New Member

Share This Page