Squirrelmail blank email list on virtual server install

Discussion in 'HOWTO-Related Questions' started by OpenSauce, Feb 18, 2011.

  1. OpenSauce

    OpenSauce New Member

    Hi all this is my first post and your help would be appreciated. I have been browsing and Googling for three days trying to solve this problem!

    I have installed "Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 9.04)" according to the tutorial but have a couple of issues which I cannot solve and would appreciate your help.

    Problem 1
    I can login to Squirrelmail with a virtual account.
    SquirrelMail shows the folders on the left but no emails in the main space. It does not say "No emails found" but just a blank frame. If there is new mail then a number appears next to Inbox which suggests that it does know where the folders are but will not display them! If I search for emails then they appear in a list and I can view them. I can send emails from the virtual account and recieve them (thanks Falko, that works well!). I have come across many suggestions about different settings for the folder prefix and tried them all but with no joy.

    Problem 2
    This may or may not be connected. If I connect to the server remotely using Thuderbird I can receive and read email with no problem. However I cannot send email (SMTP) as it does not like the password. As far as I can make out this should be the same password as is entered into the user account in MySQL as there isn't anywhere else to enter a password. As I am not yet an expert in what connects to what using this virtual server setup, I am not sure where to look to see what is not connecting properly.
    Here is the mail log entry which suggests an authorisation problem but I don't know how to resolve it.
    Code:
    Feb 18 12:00:05 server77-68-61-224 postfix/smtpd[14779]: connect from mail.steveportertransport.com[86.63.4.43]
    Feb 18 12:00:09 server77-68-61-224 postfix/smtpd[14779]: warning: SASL authentication failure: Password verification failed
    Feb 18 12:00:09 server77-68-61-224 postfix/smtpd[14779]: warning: mail.steveportertransport.com[86.63.4.43]: SASL PLAIN authentication failed: authentication failure
    Feb 18 12:00:09 server77-68-61-224 postfix/smtpd[14779]: warning: mail.steveportertransport.com[86.63.4.43]: SASL LOGIN authentication failed: authentication failure
    Feb 18 12:00:11 server77-68-61-224 postfix/smtpd[14779]: disconnect from mail.steveportertransport.com[86.63.4.43]
    I don't know what further information you may need to assist me but any help and pointers would be appreciated.

    Many thanks in advance and thanks to everyone who has posted so far.
    Mike
    Isle of Wight
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Please make sure that you introduced no PHP syntax errors when you modified any SquirrelMail files. Also take a look at your mail log if there are any errors related to this issue.

    Do you use the email address as the username? Does the left part of the email address (before @) exist as a local user account on the server?
     
  3. OpenSauce

    OpenSauce New Member

    Thanks for the reply Falko.
    I will check those points and get back to you
    Mike
     
  4. OpenSauce

    OpenSauce New Member

    Hi again Falko.
    Ref: Problem 1
    I have been fault finding through the PHP scripts by adding echo statements to filter out where the programme stopped. I ended up in right_main.php at the line
    Code:
    do_hook('right_main_after_header');
    I have commented out this one line and as if by magic, all the messages have appeared!
    Now my question is what does that line do and is it safe to leave it commented out?

    Ref Problem 2
    The username is the email address as entered in the virtual users table of the database with the relevant password. The user does not exist as a user on the local system.

    Thanks for your help so far.
    Mike
     
    Last edited: Feb 20, 2011
  5. falko

    falko Super Moderator ISPConfig Developer

    Can you restart saslauthd and Postfix and check if the authentication problem still exists?
     
  6. OpenSauce

    OpenSauce New Member

    Hi Falko
    I've restarted saslauthd and postfix but I get the same error. I can receive email in Thunderbird (IMAP) but cannot send (SMTP). Mail log shows:
    Code:
    Feb 21 08:06:03 server77-68-61-224 imapd: LOGIN, user=[email protected], ip=[::ffff:86.63.4.43], port=[39329], protocol=IMAP
    Feb 21 08:07:08 server77-68-61-224 postfix/smtpd[1103]: connect from mail.steveportertransport.com[86.63.4.43]
    Feb 21 08:07:17 server77-68-61-224 postfix/smtpd[1103]: warning: SASL authentication failure: Password verification failed
    Feb 21 08:07:17 server77-68-61-224 postfix/smtpd[1103]: warning: mail.steveportertransport.com[86.63.4.43]: SASL PLAIN authentication failed: authentication failure
    Feb 21 08:07:17 server77-68-61-224 postfix/smtpd[1103]: warning: mail.steveportertransport.com[86.63.4.43]: SASL LOGIN authentication failed: authentication failure
    Feb 21 08:07:21 server77-68-61-224 postfix/smtpd[1103]: warning: SASL authentication failure: Password verification failed
    Feb 21 08:07:21 server77-68-61-224 postfix/smtpd[1103]: warning: mail.steveportertransport.com[86.63.4.43]: SASL PLAIN authentication failed: authentication failure
    Feb 21 08:07:21 server77-68-61-224 postfix/smtpd[1103]: warning: mail.steveportertransport.com[86.63.4.43]: SASL LOGIN authentication failed: authentication failure
    Feb 21 08:07:23 server77-68-61-224 postfix/smtpd[1103]: disconnect from mail.steveportertransport.com[86.63.4.43]
    Feb 21 08:07:29 server77-68-61-224 imapd: LOGOUT, user=[email protected], ip=[::ffff:86.63.4.43], headers=0, body=0, rcvd=216, sent=962, time=86
    
    Any further ideas?

    Regarding the other problem with SquirrelMail, I have had a good look through the files and it appears that the offending line
    Code:
    do_hook('right_main_after_header');
    relates to the plugins registered (compatibility and the password change one). I have uninstalled them and reinstalled them but it still doesn't work. I shall try uninstalling them and running it without them to see if that works.

    Mike
     
  7. OpenSauce

    OpenSauce New Member

    I have used /usr/sbin/squirrelmail-configure to disable the two plugins and now Squirrelmail behaves normally with the hook line active again so it looks like it's something to do with the plugins that is causing me grief.

    Mike
     
  8. OpenSauce

    OpenSauce New Member

    Well I'm still at it!
    I have reinstalled compatibility and activated using
    Code:
    /usr/sbin/squirrelmail-configure
    and squirrelmail is fine.
    As soon as I activate change_sqlpass it kills off squirrelmail so it looks like it is a problem relating to that file.
    I shall try a complete uninstall and clean up of the plugin and reinstall it.
    Mike
     
  9. OpenSauce

    OpenSauce New Member

    Solved!!
    For future reference, I uninstalled the change_sqlpass plugin but also deleted the folder with the plugin files in it. I reinstalled it and activated the plugin and it works fine.
    This suggests that there was a problem with one of the files in the plugin directory which has now been deleted or I introduced an error when editing the confiig.php file of the plugin.
    Thank you for pointing me in the right direction, Falko.

    Now, all that remains is to work out why I cannot login using SMTP from Thunderbird....
    Answers on a postcard please :)

    Mike
     
  10. OpenSauce

    OpenSauce New Member

    Solved part2!!

    This was caused by human error (mine of course!).
    In section 6 of the guide where you need to edit /etc/default/saslauthd, I missed off the -r at the end of teh OPTIONS line. I have no idea what it does but when I added it and restarted saslauthd everything worked fine.

    My apologies to you Falko for creating work for you but thanks for pointing me in the direction that I needed to look to solve these issues.
    A great tutorial!
    Mike
     

Share This Page