Squiralmail - webmail alias not working

Discussion in 'Installation/Configuration' started by florix.net, Oct 24, 2010.

  1. florix.net

    florix.net Member

    Hi,

    I installed ISPConfig 3.0.3 on ubuntu 10.04.

    Everything is working fine except the http://www.domain.com/webmail link.

    It shows a 404 not found record.

    In /var/www i can see a symlink like this

    lrwxrwxrwx 1 root root 24 Oct 23 03:56 webmail -> /usr/share/squirrelmail/

    What could be the error?

    Please suggest.

    Richard
     
  2. till

    till Super Moderator

    This link will only work when the IP address that is used to access the server is not assigned to a website in ispconfig. There are several solutions:

    1) dont assign the ip to a website and use * instead.
    2) create a dedicated website for webmail e.g. webmail.yourdomain.com and install a webmail client of your choice into that website.
     
  3. florix.net

    florix.net Member

    Hi Till,

    Removing the IP address association from the website did the trick ...

    Now I am facing a strange problem ...

    My newly added websites are showing default web server page.

    Any idea? My webserver stopped working suddenly and I restarted the apache using /etc/init.d/apache start

    Please help ...
     
  4. till

    till Super Moderator

    Then your server requires it that you assign the IP addresses to the sites. In that case, you have to use the second method for webmail that I mentioned in my post.
     
  5. florix.net

    florix.net Member

    Florix.net

    Hi,

    Thank you for your response..

    I did the complete reinstall of ubuntu and ISPConfig 3 setup.

    I added one domain, not assigned any IP address.

    The domain name is customsurveyor.com

    In web domain setup, my values are per attachment.

    My DNS zone has entry for www record

    What value should I have for Auto sub domain .. I tried the *, www combinations but it does not work :(
     

    Attached Files:

  6. till

    till Super Moderator

    Select the IP address in the IP address field and select www for auto subdomain. By the way, why did you reinstall?
     
  7. florix.net

    florix.net Member

    Hi,

    I am using linode VPS, so reinstall was just few minutes.

    If I assign the IP, then the webmail is not working for sure.

    Now ...

    http://www.customsurveyor.com/ is going to default page
    http://customsurveyor.com/ is going to ISPConfig page

    http://customsurveyor.com/webmail not working
    http://www.customsurveyor.com/webmail is working ..

    If I assign www subdomain in domain setup, then website works with www, but webmail does not working...

    umm .. this is getting confusing :(

    Please contact me at richard a-t florix.net


    Thanks
    Richard
     
  8. ByteMe Networking

    ByteMe Networking New Member

    Maby this will help.

    I remember in cAnal when you added a new domain to your account, if setup properly it would automatically add a webmail.your.tld subdomain and would also allow your.tld/webmail to access webmail options.

    I too have been looking for the best way to do this and I am by no means an expert (like Till or Falko :eek:, One Day!:rolleyes:) but I have found a solution that worked for me.

    The following will allow all domains, subdomains, and alias domains to access webmail using (as an example) http://your.tld/webmail

    NOTE: I picked this up from some other post after hours of searching and did not bookmark the page but kept notes.

    Step one: Make your symlink for webmail (taken from Step 17 of that link)
    Code:
    ln -s /usr/share/squirrelmail/ /var/www/webmail
    Step two: Add global link for all sites
    I use nano but you can use what you want:
    Code:
    nano /etc/apache2/conf.d/apache2-doc
    Step three: Go to end of file and add
    Code:
    Alias /webmail /var/www/webmail/
    
    <Directory "/var/www/webmail/">
    Options Indexes FollowSymlinks
    AllowOverride None
    Order allow,deny
    Allow from all
    AddDefaultCharset off
    </Directory>
    
    This will work with a successful install of ISPConfig running on Debian.
    Also if you have installed using the recommended install docs on the ISPConfig website you could choose to install SquirrelMail differently by changing the folder in Step one.
    By doing so you can ultimately setup your /webmail to provide more than one webmail client.
    EX: here

    If you checked out the example you can see I offer more than just SquirrelMail but Horde and Roundcube.

    Here is the concept:
    If you follow Falko's "Perfect Setup guide" you will get to Step one (depending on your install) from the above post.

    Insted of:
    Code:
    ln -s /usr/share/squirrelmail/ /var/www/webmail
    Do
    Code:
    ln -s /usr/share/squirrelmail/ /var/www/webmail/squirrelmail
    In doing so you link squirrelmail to /webmail/squirrelmail allowing yourself to add more than one webmail client to your /webmail link.
    With some simple code you can create an index page that can point to your different webmail clients.

    EX. (If your symlinks are setup correctly)
    Code:
    <!DOCTYPE html>
    <html lang="en">
      <head>
        <title>Webmail</title>
      </head>
      <body>
    <ul>
              <li><a href="/webmail/horde">Horde</a></li>
              <li><a href="/webmail/roundcube">Roundcube</a></li>
              <li><a href="/webmail/squirrelmail">SquirrelMail</a></li>
              </ul>
      </body>
    </html>
    
    If your looking for help on how to do that please use the following link.
    http://lmgtfy.com/?q=how to write html code

    With that I hope this helped. If not please let me know if I can update this post.

    P.S.
    Falko, Till.... I just what to say thanks for the time, effort, and charity.

    Thanks,
    Casey
     
  9. rocker2344

    rocker2344 New Member

  10. falko

    falko Super Moderator

    Did you enable PHP for the aditlfai.com web site?
     

Share This Page