SquidProxy on CentOS5 ACL Problem

Discussion in 'Installation/Configuration' started by networkengineer, Jun 25, 2008.

  1. networkengineer

    networkengineer New Member

    Hi there,

    New to the forum, was wondering if anyone could help me with this snag...I've read plenty of posts on setting up squid, and this one has me stumped. The squid wiki isn't much help (more than the generic how-to)...

    acl bad url_regex "/etc/squid/squid-block.acl"
    http_access deny bad

    this should work given that I vi /etc/squid/squid-block.acl

    in squid-block.acl I have:


    so testing these sites, they go through the proxy fine...and the log shows that it passed through instead of issuing a DENY (squid.log) and so there lies my problem....

    I checked out /var/log/squid/squid.out and it tells me everything is fine (0 kb) and nothing is there...(I had errors with netmasks so I used squid.out to resolve those)...but it doesn't tell me about any errors for "acl bad" so it must be parsing correctly..

    Any suggestions?

    Also is there any .txt out there with a list of suggested blocked sites (so I don't have to type thousands of sites) or perhaps another proxy?
  2. networkengineer

    networkengineer New Member

    Solved my own problem..just in case it happens to anyone else---I recommend using webmin for the interface instead of command line--made my life much easier! The problem was with my netmask...specifying a netmask instead of /16 worked for some reason.

    Also the ACL's were all there in webmin--so no more vi to edit each of them (vi created weird block blank space characters).


Share This Page