squid problem on RHEL Release 5

Discussion in 'Server Operation' started by dogar, Aug 27, 2007.

  1. dogar

    dogar New Member

    hi all

    i have installed RHEL Release 5. when i configure the squid 2.6 on it as well as my requirement is that
    1- configure individual cache on /cache (which has isolated mount point)
    mean to say.
    # cache_dir /var/spool/squid 100 16 256
    cache_dir /cache 10000 16 256

    2- squid configure on port 80 (listening port 80 either 3128)


    but when i try to start the service of squid
    i got a error page
    cache_dir permission deny
    squid cant listen port 80

    note; i can change ownership of /cache directory from root to squid
    also crating swap directories by squid -z

    but again i can start the service of squid
    i got the same error

    plz help me for both cases.
     
  2. dogar

    dogar New Member

    hi all

    as i mentiond in above post i have two problems.the first one i have solved.the second one about port.when i change port from 3128 to 80 following error is generatd.

    "can not bind Socket FD 12 to *:80: (13) Permission denid.
    FATAL: can not open HTTP port"

    plz help me..
     
  3. falko

    falko Super Moderator ISPConfig Developer

    Ports <= 1024 are privileged, and you need root permissions to use them. Try another port (maybe 8080).
     
  4. dogar

    dogar New Member

    hi falko

    i login as root.
    Our network is consist of more then 4000 nodes and its very diffecult to change proxy settings on every machine.
    is there any other solaution ????

    bilal
     
  5. alexillsley

    alexillsley ISPConfig Developer ISPConfig Developer

    ----- expired ----
     
    Last edited: Nov 15, 2010

Share This Page