Squid Analysis installation

Discussion in 'Server Operation' started by perfectpol7, Feb 20, 2009.

  1. perfectpol7

    perfectpol7 New Member

    Hie I have a proxy server running with fedora 10. Now I need to install Squid Analysis Report Generator (sarg) but i have failed. I have tried this code: yum install sarg
    output
    Loaded plugins: refresh-packagekit
    updates | 2.3 kB 00:00
    updates/primary_db | 2.5 MB 00:56
    fedora | 2.8 kB 00:04
    Setting up Install Process
    Parsing package install arguments
    No package sarg available.
    Nothing to do

    and googled for different site come with different rpm and tar.g which also failed to install it. Is there anyone to help me install sarg on fedora 10.
     
  2. falko

    falko Super Moderator ISPConfig Developer

  3. perfectpol7

    perfectpol7 New Member

    The package sarg-2.2.5-1.fc10.rf.i386 installed. Now how would i invoke it into use.what commands should i use. I typed this code to[[email protected] ~]# /usr/local/sarg/sarg.conf
    -bash: /usr/local/sarg/sarg.conf: No such file or directory

    so where is sarg.conf reside. On webmin when i open Squid Analysis Report generator l get this:-"Module Config
    Squid Report Generator

    The Sarg configuration file /usr/local/sarg/sarg.conf was not found on your system. Maybe Sarg is not installed, or the module configuration is incorrect"

    and on module config:Configuration
    For module Squid Report Generator
    Configurable options for Squid Report Generator
    Full path to sarg executable-- (on this there is nothing and where did the sarg executabe sit, because when i tried again to install it said it already installed)
    Full path to SARG configuration file {/usr/local/sarg/sarg.conf}
    Add Webmin header and footer to SARG report? Yes No

    what is my next step to make this run or need to restart the computer.
     
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    Code:
    updatedb
    locate sarg.conf
    ?
     

Share This Page