Squeeze upgrade issue: glpi

Discussion in 'Installation/Configuration' started by crypted, Feb 8, 2011.

  1. crypted

    crypted New Member

    I've been using: http://www.howtoforge.com/upgrade-debian-lenny-to-squeeze-in-a-few-simple-steps

    Code:
    ┌───────────────────────────────────────────│ An error occurred while upgrading the database:├─────────────────────────ââ”│───────────────────────────┠                                          â”│ mysql said: ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: YES)                               â”│                                                                                                                               â”│ Fortunately, /var/cache/dbconfig-common/backups/glpi_0.70.2-2.mysql holds a backup of the database, made just before the      â”│ upgrade.                                                                                                                      â”│                                                                                                                               â”│ If at this point you choose "retry", you will be prompted with all the configuration questions once more and another attempt  â”│ will be made at performing the operation. "retry (skip questions)" will immediately attempt the operation again, skipping     â”│ all questions.  If you choose "abort", the operation will fail and you will need to downgrade, reinstall, reconfigure this    â”│ package, or otherwise manually intervene to continue using it.                                                                â”│                                                                                                                               â”│ Next step for database upgrade:                                                                                               â”│                                                                                                                               â”│                                                  abort                                                                        â”│                                                  retry                                                                        â”│                                                    retry (skip questions)                                                     â”│                                                                                                                               â”│                                                                                                                               â”│                                     <Ok>                                         <Cancel>                                     â”│                                                                                                                               â”└───────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────────┘
    
    
    
    dbconfig-common: glpi configure: aborted.                                                                                          
    dbconfig-common: flushing administrative password
    dpkg: error processing glpi (--configure):
     subprocess post-installation script returned error exit status 1
    Errors were encountered while processing:
     glpi
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    my:/etc/apt#
    I've inserted the CORRECT MySQL root password each time and it continues to fail.

    What's up with this?

    Will this break my server?

    What should I do?

    Thanks.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you accept the new /etc/mysql/my.cnf file, or did you keep your old one?
     
  3. crypted

    crypted New Member

    I kept the old one. However, the upgrade failed to install MYSQL and that was the problem I think. So, I used aptitude and installed MYSQL.

    How do I go back and get gpli to reconfigure?
     
  4. falko

    falko Super Moderator ISPConfig Developer

    Try
    Code:
    dpkg-reconfigure glpi
     
  5. crypted

    crypted New Member

    Thanks. The only bad thing about Squeeze, at this point, is the lack of volatile. ClamAV is only available at 0.95 and ISPC3 continues to warn of the update needing to be to 0.97. So for the time being, we will all be sitting here waiting for someone to get volatile going so that CLAMAV releases will be available for Squeeze.
     
  6. falko

    falko Super Moderator ISPConfig Developer

  7. crypted

    crypted New Member

    Thanks. Wonder when ClamAV will publish an update to it.
     

Share This Page