Squeeze to Wheezy -> sasl auth issues

Discussion in 'Installation/Configuration' started by Ben, Nov 3, 2013.

  1. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Hi folks,

    after finally updating my squeeze box to wheezy I had the error that sasl auth did not work anymore.

    All config files generally looked fine, also the issue I found here and on other pages in the web about changed sql plugin name, but this was not the issue in my case.

    The only thing that helped was to downgrade sasl to the packages from squeeze. But this feels like a temporary solution, especialy because of unsolved dependencies and thus annyoing cron-apt mails about those issues (instead of just updates that are available).

    Did anyone run into the same issue and found a better solution?

    Is there maybe some solution to totally get rid of saslauth in an ispconfig3 setup?

    Thanks in advance.
     
  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    I think you are using dovecot, right?

    Please try installing dovecot-managesieved
    Code:
    apt-get install dovecot-managesieved
    Then try creating a new config for dovecot2 like this:
    Code:
    cd /etc/dovecot
    dovecot -n > dovecot.conf-new
    mv dovecot.conf dovecot.conf.save ; mv dovecot.conf-new dovecot.conf ; /etc/init.d/dovecot restart
    
     
  3. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Hi Croydon,

    nope I use typical postfix with saslauth (-> mysql) for smtp(s) and courier for imap(s) / pop3(s) connections.
    But receiving the emails is not issue at all, the only problem is authentication via SMTP.

    If I do not downgrade to the squeeze saslauth packages, saslauth is not working at all.
    (which is because of the old saslauth packages).

    If I upgrade, smpt auth is not possible anymore.

    and this is what the smtpd.conf looks like (if that helps)
    From what I found googling this is already fine, as one issue was for some people, that after the ugprade this file needed to be changed, e.g. the axuprop_plugin value from sql to mysql etc.
     
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have you done an ISPConfig update after you upgraded debian?
    This is neccessary so ISPConfig writes the new configs.
     
  5. Ben

    Ben ISPConfig Developer ISPConfig Developer

    yes I did. So the timeline was

    - upgrade
    - reboot
    - detected the issue and stared research
    - checked all config files, postfix chrooted env to work properly
    - "upgraded" IPSConfig, letting the installer reconfigure all services (to generate new config files)
    -> No luck
    - Installed squeeze SASL packages that worked out eventhough having those warnings.

    But I just wondert, how it worked out for all the others :/
     
  6. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    That's really quite strange - although I'd never use squeeze packages on wheezy.
    Sorry, no further idea at the moment, maybe someone else has some.
     
  7. Ben

    Ben ISPConfig Developer ISPConfig Developer

    But to get you right, you have a similar setup running, meaning Debian Wheezy, ISPConfig 3 with sasldbauth, without any problems?

    Thanks for your help anyway.
     
  8. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    I have multiple servers on debian wheezy (updated from squeeze).

    Some with dovecot, some with courier, all up and running, yes.
     
  9. Ben

    Ben ISPConfig Developer ISPConfig Developer

    it is totally weird.... just tried again (verified some howtos to the setting I have, upgraded to the newest sasl packages).

    - telnet auth (plain and login) and some online test pages work fine.

    - auth plain via Mail.App, Outlook, Thunderbird, as well as postfix as client did not work at all. no clue why, especially that manau auth plain works, "plain" for the clients mentioned before does not.....


    is there any other possiblity to authenticate postfix users for sending mails via DB except SASL?
     
  10. stef157

    stef157 Member

    Try to reconfigure the service from ISPConfig update ;-)
     
  11. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Well what should I say, finally I found it :)

    It was that on some mailboxes "postfix" was set to "n" in the mail_user table.
    This setting corresponds with the label of "receive emails / aktiviere empfang".
    As those accounts were created to only send mails and not to receive emails I set this option intentionally to "no". But due to that sql query with "postfix = 'Y'" in the WHERE clause that fails.

    @Till / Falko: Could you please check that if that might be a bug? Because from my perspective right now, sending mails fails if that option is set to not receive emails...

    Thanks Ben
     

Share This Page