SpamSnake resource hungry

Discussion in 'Installation/Configuration' started by alleks, Feb 25, 2011.

  1. alleks

    alleks Member

    Hello folks, I have a problem with a server of mine that I run the SpamSnake server (configured following this tutorial)

    The problem is that the one of the apps maintains clean the filter's db, is very cpu hungry.

    I have 4 times the same process with Time starting from 32H to 333H and CPU consumption between 23.0-24.0 and that multiplied by 4 gives me a 100% cpu consumption, that's not good at all.

    What I mean is that fuzzy-cleanmysql, starts but never ends, and processes keep starting even if there is already 1 on.

    I have attached 2 photos so you can see what I am talking about. Hope some1 is able to help me.

    Tnx,
    alex
     

    Attached Files:

    Last edited: Feb 25, 2011
  2. Rocky

    Rocky New Member

    Please disable the script for now. I'll try to get it fixed soon.
     
  3. alleks

    alleks Member

    Thank you,
    and please let me know if you need any help and if not, what was the problem :)

    Alex
     
  4. Rocky

    Rocky New Member

    Hey,
    If you're savy with scripting, give it a shot. It's a script I found on the fuzzy website and modified it to work with the snake, so I didn't write it. It works on my system just fine, I'm not sure what's happening with yours.

    Go ahead and open fuzzyclean-mysql and enable verbose, just set it to 1. Run the script and see what it tells you. Report back with your log.
     
    Last edited: Feb 25, 2011
  5. alleks

    alleks Member

    Ok I am going to do it this weekend, couse now (friday 13:41) I am at work and busy setting up some new servers for the new CPD.

    I'll keep you up to date with my progress.
     
  6. alleks

    alleks Member

    Any update on this?

    I had no time to work with it, I will have a look when I can.
     
  7. Rocky

    Rocky New Member

    Yes, please delete your current script and recreate it using the updated script from the guide.
     
  8. alleks

    alleks Member

    Ok, here I am yet with another question

    The Fuzzy clean mysql script has these 2 variables
    Code:
    db_hash => '/var/lib/fuzzyocr/FuzzyOcr.db',
    db_safe => '/var/lib/fuzzyocr/FuzzyOcr.safe.db',
    the problem is that I don't have the fuzzyocr folder in /var/lib but according to vi /etc/spamassassin/FuzzyOcr.cf file, they are located here

    Code:
    focr_db_hash /etc/spamassassin/FuzzyOcr.db
    focr_db_safe /etc/spamassassin/FuzzyOcr.safe.db
    and with that ofcourse fuzzy script to clean mysql won't work

    Any opinions?
     
  9. Rocky

    Rocky New Member

    Hey,

    Make sure your hashing option is setup for option 3 in FuzzyOcr.cf. This logs everything to mysql and not a text based db. Thus, this will allow the cleaner script to work.

    Rocky.
     
  10. alleks

    alleks Member

    Here are all of my active variables that has anything to do with hashing in "/etc/spamassassin/FuzzyOcr.cf"

    focr_enable_image_hashing 3
    focr_digest_db /etc/spamassassin/FuzzyOcr.hashdb
    focr_db_hash /etc/spamassassin/FuzzyOcr.db
    focr_db_safe /etc/spamassassin/FuzzyOcr.safe.db

    and still no result
     
  11. Rocky

    Rocky New Member

    What do you have in your fuzzy log? is it populating the fuzzy db?

    If you're still experiencing the loop problem, try setting

    while () {
    to
    while(<CONFIG>) {

    This should prevent the loop from occuring.
     
  12. alleks

    alleks Member

    I didnĀ“t post the FuzzOcr.log file because there are no errors in it, it seams to populate and work correctly.

    I've updated the fuzzy file with the way you told me, now it doesn't load the server but it does nothing :D. That's because it just simply can't the the file, right?
     
  13. Rocky

    Rocky New Member

    vi /usr/sbin/fuzzy-cleanmysql and set
    my $verbose = 0;
    to
    my $verbose = 1;

    Run the script and you should see output. It should report errors, if any. Otherwise, it's working fine.

    You can check your fuzzy mysql db to see if it's cleaning out old records.

    First log in, check your db to see if records are there, should be 10days. Then set
    $age{'age'} = 10*24; # 10 days
    to
    $age{'age'} = 1*24; # 1 day

    Run the script and it should only keep 1 days worth of results. Check your db again to verify. If records were removed, then it's working.
     

Share This Page