Spamsnake - Mail Transport Unavailable Issue

Discussion in 'HOWTO-Related Questions' started by frogman, Oct 25, 2009.

  1. frogman

    frogman New Member HowtoForge Supporter

    I believe I have followed The Perfect SpamSnake - Ubuntu Jaunty Jackalope -Howto to the letter...

    I am down to what I hope is my final challenge:

    Incoming messages are getting stuck after content scanning in the postfix queue. When forcing a flush on the queue, I get the following in the log:

    Oct 25 17:16:55 spamsnake postfix/qmgr[4015]: 12361BE9BB: from=<[email protected]>, size=2853, nrcpt=1 (queue active)
    Oct 25 17:16:55 spamsnake postfix/qmgr[4015]: warning: connect to transport SMTP: No such file or directory
    Oct 25 17:16:55 spamsnake postfix/error[4439]: 12361BE9BB: to=<[email protected]>, relay=none, delay=8858, delays=8858/0.03/0/0.02, dsn=4.3.0, status=deferred (mail transport unavailable)

    transportdomain.tld refers to a single transport domain that I have defined.

    Is anyone else experiencing this issue? Any thoughts?
  2. Tyiell

    Tyiell New Member

    I feel your pain - I have a similar problem (my thread). Does your mailwatch front end show any stats on what its stopping/scanning/etc?

  3. frogman

    frogman New Member HowtoForge Supporter


    Thanks for the reply. Mine is actually making it through the scanning/scoring, etc. all the way to the Outgoing queue. Looks like it is trying to get out, then I get the SMTP unavailable message.

    I have also installed Webmin to more easily manage Postfix and can see the messages stuck in there. Forcing a release (postqueue -f) generates the same error.

    Other mail, like from the cron jobs out to another Internet mailbox are working, which makes this even more strange.

    I had previously followed the 8.04 Ubuntu Howto which had several issues, but I did get that one to release the mail. My next step here is to go through the configuration settings from that one and see what is different...

  4. Tyiell

    Tyiell New Member

    I'll not be much help then - I'll probably get the problem you're having if I ever fix my own!! It's driving me mad at the moment but I'll keep you updated if mine starts behaving :)

    Good luck!
  5. Rocky

    Rocky New Member


    Does your line in match the following?
    smtp inet n - - - - smtpd
  6. frogman

    frogman New Member HowtoForge Supporter


    yes, that is exactly what it says in

    smtp inet n - - - - smtpd
  7. Rocky

    Rocky New Member

    Ok, did you uninstall apparmor?

    Also, recreate your transport file for posfix. Make sure to postmap it and restart postfix when finished.
  8. frogman

    frogman New Member HowtoForge Supporter


    Thanks for the reply... I have recreated transport and postmap'd it. And re-executed the commands to stop apparmor and remove it from init.d - NO CHANGE, unfortunately.

    BUT, I stopped short of an aptitude remove because it says it will REMOVE a bunch of other stuff.

    root@spamsnake:~# aptitude remove apparmor apparmor-utils
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Reading extended state information
    Initializing package states... Done
    The following packages will be REMOVED:
    clamav{u} clamav-base{u} clamav-daemon{u} clamav-freshclam{u}
    libclamav6{u} libconvert-binhex-perl{u} libconvert-tnef-perl{u}
    libdbd-sqlite3-perl{u} liberror-perl{u} libfilesys-df-perl{u}
    libio-socket-inet6-perl{u} libio-stringy-perl{u} libmail-spf-perl{u}
    libmime-perl{u} libmime-tools-perl{u} libnet-cidr-lite-perl{u}
    libnet-cidr-perl{u} libnetaddr-ip-perl{u} libole-storage-lite-perl{u}
    libsocket6-perl{u} libsys-hostname-long-perl{u} libsys-syslog-perl{u}
    libtommath0{u} re2c{u} spamassassin{u} spamc{u} tnef{u}
    0 packages upgraded, 0 newly installed, 27 to remove and 0 not upgraded.
    Need to get 0B of archives. After unpacking 33.7MB will be freed.
    Do you want to continue? [Y/n/?]

    I said No at this point. Should I let it remove these items? I figured unloading the service and removing it from init.d would suffice and I did not want to break anything else... Thoughts?

    One item that I do not think is relevant, but anyway... One step (16.4) that doesn't work for me is when trying to manually start mailscanner at the command prompt. It seems as though the /opt/MailScanner...etc.. is not in the path as the original apt-get install of Mailscanner is. But, it is started by the cron job check_mailscanner or I start it from within /opt/etc/MailScanner/bin... I also created a ln -s from etc/MailScanner to /opt/MailScanner

    I appreciate yours and anyone else's help!!

  9. Tyiell

    Tyiell New Member

    Just to let you know that having solved a few of my problems, I am now (as predicted) stuck with the exact problem you have!! Mail Transport Unavailable. I have gone thorugh the same steps you have in this thread with the same results, so please keep me informed if you fix it!!!! I'll obviously do the same if I get lucky :)

    Many thanks,

  10. Rocky

    Rocky New Member


    Please post your transport, relay and file.
  11. frogman

    frogman New Member HowtoForge Supporter

    Thanks, Rocky...

    I took your suggestion of rebuilding the transport file and rebuilt that as well as the relay_domains and relay_recipients files.

    I ALSO deleted the .db files to be sure they were recreated. Perhaps you meant for me to do that in the first place, but I did not the first time around.

    I am not sure why, but this FIXED IT !!! Mail is now flowing all the way through and looks like everything is working properly.

    Thanks Again... Do you know why this worked? Since you suggested it, I suppose you have seen it before? Any insight as to what is happening there?

  12. Rocky

    Rocky New Member

    This happened to me a 2yrs ago with the original spamsnake. I was busting my brains trying to figure it out and did the same as you. I did make a mistake in my transport file, which I caught, and it was causing the problem. However, even after I fixed the entry and postmapped it, it didn't work. So I too did what you did, and it worked.

    So congrats and have fun. Hope it works out for you.

  13. Tyiell

    Tyiell New Member

    OK, this might be a dumb question - but how did you recreate the .db files? I deleted mine and restarted postfix and they were not re-created. Now postfix doesn't work at all!!! :eek:
  14. Tyiell

    Tyiell New Member

    Yep, was a dumb question. Re-postmapped them, et voila :D
  15. frogman

    frogman New Member HowtoForge Supporter


    So did this resolve the SMTP unavailable issue?
  16. Tyiell

    Tyiell New Member

    Er, no :(

    But in researching, I cant help but question whether I should have added the line that Rocky told you to add below - you said you already had it, but I did not - it wasnt in the guide and whilst I cheerfully added it in, I dont actually seem to have an smtpd service running....

    smtp n - - - - smtpd
    Im so confused now I think I need to leave it alone and come back later before I do something daft!
  17. Rocky

    Rocky New Member

    You didn't have a line like that in your It should be at the very top.

    If you didn't, this would lead me to believe that your install was incorrect, as this line should be there by default.

Share This Page