SpamSnake Issue

Discussion in 'HOWTO-Related Questions' started by sypmaster, Feb 6, 2009.

  1. sypmaster

    sypmaster New Member

    Hi folks.

    I am having a little issue in the spamsnake solution.

    I have complete the setup, and it is in production now. All the rules work fine except for one thing.

    When i go to Reports/Mail Operations inside Mailwatch I see a message waiting for me to take one action.

    I click in Release, since it is a valid message, and learn. It gives me a Spam Learn Results empty with the back option. I click in back and the message still there.

    It seems that the do_message_ops.php and the detail.php are not working properly. I have edited the quarantine_maint.php and see that this parameter is not valid, require('/var/www/html/mailscanner/functions.php') since it points to this wrong location. I fixed the path.

    So I am unable to release messages from quarantine. Any clues of what is happening?
     
  2. Rocky

    Rocky New Member

    Hey,

    The message will remain in the system, since it's being kept as a quarantined copy.

    When you click release, a copy of the message should be sent to the email address it was originally being sent to.

    Rocky
     
  3. sypmaster

    sypmaster New Member

    But Rock, I tough if i hit release, the message should be send to the original recepie, since it could be a false positive.

    Even if i choose the other options nothing happens.

    Understand my doubt?

     
  4. Rocky

    Rocky New Member

    I understand what you're saying. But remember, mailscanner is setup to keep a local copy. This copy is therefore accessible through the quarantine option of mailwatch for training purposes. So the message will not be removed from the system, but you should get a message release confirmation at the bottom of the page after you release a message. It'll say something like, message released to [email protected].

    If that's not working for you, then I suspect that you have permission issues. I would double check the permission on the /var/spool folders.

    Rocky
     
  5. sypmaster

    sypmaster New Member

    Well here is a quick look at the /var/spool permissions. Everything seems fine.

    drwxr-x--- 6 postfix www-data 4096 2009-01-30 12:16 MailScanner
    drwxr-xr-x 19 root root 4096 2009-01-29 17:15 postfix

    Inside MailScanner
    drwxr-x--- 2 postfix www-data 4096 2008-04-04 23:00 archive
    drwxr-x--- 34 postfix www-data 4096 2009-03-06 16:52 incoming
    drwxr-x--- 6 postfix www-data 4096 2009-03-05 13:38 quarantine
    drwxr-xr-x 2 postfix www-data 4096 2009-01-30 12:16 spamassassin

    Inside Quarantine

    drwx------ 3 postfix www-data 4096 2009-02-26 10:44 20090226
    drwx------ 3 postfix www-data 4096 2009-03-02 15:18 20090302
    drwx------ 6 postfix www-data 4096 2009-03-04 18:09 20090304
    drwx------ 6 postfix www-data 4096 2009-03-05 23:04 20090305

    And go on all wit postfix:www-data permissons.

    When i release a message i do no get this message. Just a blank line and the back option.
     
  6. ScarEye

    ScarEye New Member

    sypmater,

    I am having the same issue, were you able to reslove this problem?


    Thanks in advance,
    ScarEye
     
  7. Rocky

    Rocky New Member

    Do you have the following set /var/www/mailscanner/conf.php:

    define(QUARANTINE_USE_FLAG, true);
    define(QUARANTINE_FROM_ADDR, '[email protected]');
    define(QUARANTINE_USE_SENDMAIL, false);

    *Make sure to replace [email protected] with a valid email.

    Might also want to redo the following:

    Try the following:

    Code:
    chown -R postfix:www-data /var/spool/MailScanner

    If the above works, then you're good to go. If not, make sure the following settings are correct in /etc/MailScanner/MailScanner.conf:

    Code:
    Quarantine User = root
    Quarantine Group = www-data
    Quarantine Permissions = 0660
    Quarantine Whole Message = yes
    Always Looked Up Last = &MailWatchLogging
     
    Last edited: Sep 9, 2009

Share This Page