spamsnake installation error

Discussion in 'HOWTO-Related Questions' started by davy, May 18, 2008.

  1. davy

    davy New Member

    hi,

    I got the below error about mailscanner and clamav.Can anybody help me to solve this problems.

    Mailscanner:

    [email protected]:~# apt-get install libconvert-tnef-perl libdbd-sqlite3-perl libfilesys-df-perl libmailtools-perl libmime-tools-perl libmime-perl libnet-cidr-perl libsys-syslog-perl libio-stringy-perl libfile-temp-perl
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    libconvert-tnef-perl is already the newest version.
    libdbd-sqlite3-perl is already the newest version.
    libfilesys-df-perl is already the newest version.
    libmailtools-perl is already the newest version.
    libmailtools-perl set to manually installed.
    libmime-tools-perl is already the newest version.
    libmime-tools-perl set to manually installed.
    libmime-perl is already the newest version.
    libmime-perl set to manually installed.
    libnet-cidr-perl is already the newest version.
    libsys-syslog-perl is already the newest version.
    libio-stringy-perl is already the newest version.
    libio-stringy-perl set to manually installed.
    libfile-temp-perl is already the newest version.
    libfile-temp-perl set to manually installed.
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    mailscanner: Depends: libarchive-zip-perl (>= 1.16) but it is not going to be installed
    Depends: unzip but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    [email protected]:~#

    clamav:

    [email protected]:~# apt-get install clamav clamav-daemon
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    clamav: Depends: clamav-freshclam but it is not going to be installed or
    clamav-data
    Depends: libclamav3 (>= 0.92.1~dfsg2) but it is not going to be installed
    Depends: libgmp3c2 but it is not going to be installed
    clamav-daemon: Depends: clamav-base (>= 0.92.1~dfsg2-1.1) but it is not going to be installed
    Depends: clamav-freshclam but it is not going to be installed or
    clamav-data
    Depends: libclamav3 (>= 0.92.1~dfsg2) but it is not going to be installed
    mailscanner: Depends: libarchive-zip-perl (>= 1.16) but it is not going to be installed
    Depends: unzip but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    [email protected]:~#


    Thanks alot.
     
  2. Rocky

    Rocky New Member

    Hi,

    Couple of questions.

    Did you follow the guide from the beginning?

    Have you tried the apt-get -f install?
     
  3. davy

    davy New Member

    Yes. I did.

    Mailscanner:

    [email protected]:~# apt-get -f install libarchive-zip-perl
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run `apt-get -f install' to correct these:
    The following packages have unmet dependencies:
    mailscanner: Depends: unzip but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

    Thank you for your reply.
     
  4. Rocky

    Rocky New Member

    Hi,

    I think you're doing it wrong. You need to type apt-get -f install only, without any packages.
     
  5. davy

    davy New Member

    Thank you very much.
     

Share This Page