SpamSnake - check_mailscanner: command not found

Discussion in 'HOWTO-Related Questions' started by mrtero, Jun 16, 2009.

  1. mrtero

    mrtero New Member

    Hey : )

    Just want to clarify, and if necessary, find a solution to this problem, so that others that encounters this problem, may find the answer here : )

    Guide: The Perfect SpamSnake - Ubuntu Jaunty Jackalope

    I'm currently at step 16.4 Start the system, and I encounter the following error when i run the command: check_mailscanner
    Code:
    [email protected]:/opt/MailScanner-4.75.11-1/bin# check_mailscanner
    -bash: check_mailscanner: command not found
    At the same time, I tried to run the command i added to Cron in step 16.3 Create cron jobs to keep MailScanner updated:, and here's the output of that:
    Code:
    /opt/MailScanner/bin/check_mailscanner
    Code:
    [email protected]:/opt/MailScanner-4.75.11-1/bin# /opt/MailScanner/bin/check_mailscanner
    MailScanner running with pid 18727 19706 19708 19710 19712 19714
    So my question then, would be, is this a serious problem for this guide to work? and if so, how can we/I solve it? =)

    Thanks in advance
     
  2. mrtero

    mrtero New Member

    reinstalled but still running with the same error :-/

    Code:
    [email protected]:~# check_mailscanner
    -bash: check_mailscanner: command not found
    but
    Code:
    [email protected]:~# /opt/MailScanner/bin/check_mailscanner
    Starting MailScanner... Done.
    works fine :p

    Saw this durinf the mailscanner installation:
    But as far as I know, we have not made any changes to this ?

    But then again, this could all just be a "misstype" : )
     
  3. moomooboy

    moomooboy New Member

    I think i know this one =p

    it's because you don't have a link in /bin

    when you run check_mailscanner it searches the env(environment)

    if you type 'env' look under PATH=

    they are the location it looks for check_mailscanner

    the reason why the other one work is because you ran it from where it was!

    to fix this problem, i think you need to use the ln -s source destination

    ^ please don't trust my answers, i'm 55% sure on this one =p, been reading a lot of linux books lol ^^

    hopefully the seniors can help you out on this!.. but i think i'm pretty sure as i've done this other guide :D
     
  4. mrtero

    mrtero New Member

    huuum, thanks for the reply :D
    Always appreciated ;D

    Not sure how I'm supose to solv this with "ln -s" but I can always google it ;D

    Atleast now, I have some pointers to follow :D thanks a lot!
     

Share This Page