spamassassin upgrade unsafe ownership

Discussion in 'Installation/Configuration' started by chief, Oct 11, 2021 at 2:28 PM.

  1. chief

    chief Member HowtoForge Supporter

    Hi,
    Debain 9, ispconfig 3.2.2
    I updated the software and have now this issue..
    Code:
    Reading changelogs... Done
    (Reading database ... 54085 files and directories currently installed.)
    Preparing to unpack .../libruby2.3_2.3.3-1+deb9u10_amd64.deb ...
    Unpacking libruby2.3:amd64 (2.3.3-1+deb9u10) over (2.3.3-1+deb9u9) ...
    Preparing to unpack .../ruby2.3_2.3.3-1+deb9u10_amd64.deb ...
    Unpacking ruby2.3 (2.3.3-1+deb9u10) over (2.3.3-1+deb9u9) ...
    Setting up spamassassin (3.4.2-1~deb9u4) ...
    gpg: WARNING: unsafe ownership on homedir '/var/lib/spamassassin/sa-update-keys'
    gpg: failed to create temporary file '/var/lib/spamassassin/sa-update-keys/.#lk0x00005somerandomthings0.mail.......co.uk.19662': Permission denied
    gpg: keyblock resource '/var/lib/spamassassin/sa-update-keys/pubring.kbx': Permission denied
    gpg: no writable keyring found: Not found
    gpg: error reading '/usr/share/spamassassin/GPG.KEY': General error
    gpg: import from '/usr/share/spamassassin/GPG.KEY' failed: General error
    gpg: process '/usr/bin/gpg --homedir='/var/lib/spamassassin/sa-update-keys' --batch --no-tty --status-fd=1 -q --logger-fd=1 --import' finished: exit 2
    dpkg: error processing package spamassassin (--configure):
     subprocess installed post-installation script returned error exit status 2
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    dpkg: dependency problems prevent configuration of sa-compile:
     sa-compile depends on spamassassin; however:
      Package spamassassin is not configured yet.
    
    dpkg: error processing package sa-compile (--configure):
     dependency problems - leaving unconfigured
    Processing triggers for man-db (2.7.6.1-2) ...
    Setting up libruby2.3:amd64 (2.3.3-1+deb9u10) ...
    Setting up ruby2.3 (2.3.3-1+deb9u10) ...
    Processing triggers for libc-bin (2.24-11+deb9u4) ...
    Errors were encountered while processing:
     spamassassin
     sa-compile
    
    and now getting a ton load of more spam because of it... damn spammers
     

Share This Page