spamassassin unable to initialize database

Discussion in 'Server Operation' started by alleks, Jan 25, 2011.

  1. alleks

    alleks Member

    Greylist/Fix, SpamAssassin problems

    Hi there, I am trying to setup a server using the Ubuntu 10.10 SpamSnake Server tutorial, but when I get to the line where I have to run this command:
    Code:
    spamassassin -x -D -p /opt/MailScanner/etc/spam.assassin.prefs.conf --lint
    I get
    Code:
    dbg: bayes: unable to initialize database for root user, aborting!
    Instead of
    Code:
    debug: bayes: Using userid: 2
    Any ideas?

    Thank you,
    w0rldart
     
    Last edited: Jan 26, 2011
  2. Rocky

    Rocky New Member

  3. alleks

    alleks Member

    I have solved that problem by running doing these steps (My SpamAssassin Version: 3.3)

    Code:
    #sa-learn --sync
    #spamassassin -x -D -p /opt/MailScanner/etc/spam.assassin.prefs.conf --lint
    
    But now I have another problem relating to postfix and mailscanner

    I get this error in my logs and for that the MailScanner won't filter

    Code:
     warning: connect to private/greyfix: No such file or directory
    Any idea?
     
  4. Rocky

    Rocky New Member

    Did you install greyfix and do you have the following in master.cf:

    greyfix unix - n n - - spawn
    user=nobody argv=/usr/local/sbin/greyfix --greylist-delay 60 -/ 24
     
  5. alleks

    alleks Member

    Ok I had to install greyfix and add that to master.cf (did it before you answer) but now there is another problem... every single mail gets dropped by the greylist/greyfix. Why could that be?

    This is what I added in my master.cf, I don't think that by not adding --greylist-delay 60 will cause to drop the emails.

    Code:
    greyfix    unix  -       n       n       -       -       spawn
      user=nobody argv=/usr/local/sbin/greyfix -/ 24
    

    BTW, I have 2 servers (2 VMs, 1 for testing and 1 that's live) and both share the same SpamSnake Ubuntu 10.10 setup... but I don't have these problems on my testing server. That's weird.

    ---------------------------------------------------------------------------------------------------------------------------
    Edit:

    I've added the --greylist-delay 60, and the same result

    This is what I get in my logs with greylist/fix on

    Code:
    [B][I]NOQUEUE: reject: RCPT[/I][/B] from mail-ww0-f50.google.com[74.125.82.50]: 450 4.7.1 <[B]destination@mymail.com[/B]>:
     Recipient address rejected: Greylisted by greyfix 0.3.9, try again in 60 seconds.
     See http://www.kim-minh.com/pub/greyfix/ for more information.;
     from=<[B]sender@gmail.com[/B]> to=<[B]destination@mymail.com[/B]> proto=ESMTP helo=<mail-ww0-f50.google.com>
    
    destination@mymail.com => my email account were I am receiving the emails
    sender@gmail.com => my other email from which I send the email, could be gmail or hotmail or any other domain... result is the same
     
    Last edited: Jan 26, 2011
  6. Rocky

    Rocky New Member

    Hey,

    Thats the default behavior of greyfix. It rejects a message the first time it sees it and accepts it after 60 seconds if it comes back. This is a way of preventing spam as some spambots does not resent messages.

    If you want, you can whitelist your sender address in Baruwa and postfix will skip checks on it, providing you have the global whitelist section done. This will prove if the system is working as it should.

    Rocky
     

Share This Page