Spamassassin not working - ISPConfig v2.2.39 / CentOS 5.6 / postfix

Discussion in 'Installation/Configuration' started by Fairbanks, Aug 22, 2011.

  1. Fairbanks

    Fairbanks New Member

    I’m running an ISPConfig server over CentOS 5.6. I followed the perfect setup from ISPConfig.org but now running the platform for a few weeks and trying to setup mail account with SPAM / Virus, I realize that those filters are not working (I do not get any effect regardless of what I do in the config panel e.g. re-write, discard, score changes, …).

    Please, let me know what kind of info you need for diagnosis purposes as I don’t even know where to start…

    Thanks,
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Are there any errors in your mail log (in the /var/log/ directory)?
     
  3. Fairbanks

    Fairbanks New Member

    Not that I see (or not obvious). There's something about "Freshclam" updating ClamAV signatures. Other then that, regular connect/disconnect as mails are routed.

    What am I looking for...
     
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Do you get any errors when you run:

    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint

    you might also want to run this command to update the spamassassin rules:

    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
     
  5. Fairbanks

    Fairbanks New Member

    Below is what I got (I ran the update after getting the first warning). Something to worry about "the Line 65" message...

    [root ~]# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
    Subroutine IO::Socket::INET6::AF_INET6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 65.
    at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16
    config: no rules were found! Do you need to run 'sa-update'?
    [root ~]# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
    [root ~]# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
    Subroutine IO::Socket::INET6::AF_INET6 redefined at /usr/lib/perl5/5.8.8/Exporter.pm line 65.
    at /usr/lib/perl5/vendor_perl/5.8.8/IO/Socket/INET6.pm line 16
    [[email protected] ~]#
     
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The rules were missing, I think it should work now after the sa-update run even with the line 65 error.
     
  7. Fairbanks

    Fairbanks New Member

    Thanks "for now" Till. It won't be long before I see Spam coming my way, so I will let you know shorthly if things are better or not.

    Should I CRON this update or is it done thru regular ISPConfig processes ?...
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    You can create a cronjob for that.
     
  9. Fairbanks

    Fairbanks New Member

    Well - THANKS Till.

    I got an email re-written to "[*** SPAM ***]-[Score 17.8]" ...

    I can now play with the ISPConfig setup and finetune what I want to do with those eMails (discard, or accept and flush with Outlook...).

    Thanks Again.

    G
     

Share This Page