spamassassin not working - debian 3.1

Discussion in 'Installation/Configuration' started by fulltilt, Oct 19, 2006.

  1. fulltilt

    fulltilt New Member

    i have problems with spamassassin:

    :~# cat /tmp/output.txt | grep fail
    [2123] dbg: diag: module not installed: Net::Ident ('require' failed)
    [2123] dbg: bayes: opportunistic call attempt failed, DB not readable

    :~# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update --
    error: gpg required but not found!

    if i try to update with:
    :~# /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update --
    error: gpg required but not found!

    how can i fix spamassassin - running on debian 3.1 (postfix)
    installed by:
    The (Almost) Perfect Setup - Debian Sarge (3.1) On A Strato Dedicated-Server (With ISPConfig)

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please install the Net::Ident per module and the gpg package from your linux distribution.
  3. fulltilt

    fulltilt New Member

    thanks till,

    Net::Ident is working now ...
    but next problem is:

    :~# cat /tmp/output.txt | grep fail
    [2154] dbg: bayes: opportunistic call attempt failed, DB not readable

    is that a problem or depends it only on empty db?

    also i have problems with clamav:
    i get the warning message ... please upgrade clamav ....
    is there a howto for upgrade clamav in ISPconfig?

  4. falko

    falko Super Moderator ISPConfig Developer

    There will be a new ClamAV package in the next ISPConfig update, so there's no need to update it manually.
  5. gcoram

    gcoram New Member

    Using debian I found had to guess a lot of required packages, then the path that sa-update has does not include /usr/bin even though $PATH does, go figure :eek:
    so at this point I just cheated with
    ln -sf /usr/bin/gpg /usr/sbin/gpg
    problem solved, all good :cool:

Share This Page