Spamassassin not working after upgrade to 2.2.37

Discussion in 'Installation/Configuration' started by torusturtle, Dec 11, 2010.

  1. torusturtle

    torusturtle ISPConfig Developer

    Hi

    I upgraded my system from 2.2.35 to 2.2.37.
    While upgrading I installed the needed packages for spamassassin.
    Code:
    aptitude install libnetaddr-ip-perl libarchive-tar-perl
    I received no error while installing 2.2.37.

    No all the spam is forwarded without checking to the user email account.

    There seems no spamassassin instance running on my server.

    Code:
    # ps ax | grep spam
     4227 pts/0    R+     0:00 grep spam
    # ps aux | grep amavis
    root     10490  0.0  0.0   5164   788 pts/0    S+   15:43   0:00 grep amavis
    # ps aux | grep assassin
    root     15398  0.0  0.0   5164   776 pts/0    R+   16:12   0:00 grep assassin
    
    Any ideas?

    Thanks!

    P.S. I'm running Debian Lenny
     
    Last edited: Dec 11, 2010
  2. dimas

    dimas Member

    The same situation here, on two different servers.
     
  3. falko

    falko Super Moderator

    Does
    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/spamassassin --lint
    show any errors?
     
  4. dimas

    dimas Member

    Running this on my both systems results with "command not found" error, although spamassassin does reside inside the folder.
     
    Last edited: Dec 12, 2010
  5. torusturtle

    torusturtle ISPConfig Developer

    [solved]

    Thanks for that command.
    I think I found the problem.


    I received the following message:
    Code:
    config: no rules were found!  Do you need to run 'sa-update'?
    so I ran
    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
    and got
    Code:
    Can't locate LWP/UserAgent.pm in @INC (@INC contains: /home/admispconfig/ispconfig/tools/spamassassin/usr/share/perl/5.10.0 /etc/perl /usr/local/lib/perl/5.10.0 /usr/local/share/perl/5.10.0 /usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl) at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 81.
    BEGIN failed--compilation aborted at /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update line 81.
    
    so I installed libwww-perl
    Code:
    aptitude install libwww-perl
    now neither sa-update nor spamassassin --lint give me any message.
    I also didn't receive any spam for several minutes now and there are spamassassin processes running :)

    I didn't find the above package in the perfect setup for Lenny. Maybe it should be added.
     
  6. dimas

    dimas Member

    Thank you, it seems to be working now, I did as suggested in the previous post, only I ran

    apt-get install libwww-perl

    which is pretty much the same, as I understand

    No spam now, at least at the moment.
     
  7. torusturtle

    torusturtle ISPConfig Developer

    Cool, that it helped you too.

    Yes. In this case apt-get and aptitude do the same.
    Here is a nice comparison of apt-get and aptitude.
     
  8. mccharlet

    mccharlet HowtoForge Supporter

    For information,

    I have the same problem for update 2.2.37 to 2.2.40
     
  9. falko

    falko Super Moderator

    Could you solve it with
    Code:
    aptitude install libwww-perl
    ?
     
  10. mccharlet

    mccharlet HowtoForge Supporter

    Hi


    I received the following message:

    Code:
    config: no rules were found!  Do you need to run 'sa-update'?so I ran 
    and i run this for resolve the problem

    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
     

Share This Page