spamassassin local.cf processing and forcing x-spam-status

Discussion in 'Installation/Configuration' started by billcouper81, Mar 13, 2010.

  1. billcouper81

    billcouper81 New Member

    I am trying to tune the spam filtering on a mail server that I manage

    The mail server uses ISPConfig3 (with Postfix and SpamAssassin). ISPConfig is 3.0.16. SpamAssassin is 3.2.5 running on Perl 5.10.0.

    There are a number of DNS Blacklists setup in the postfix main.cf but spam is getting through still so I wanted to customise the spamassassin settings

    I am trying to implement some basic filter rules via local.cf

    Another problem is that non-spam doesn't have any x-spam-status header to help tune the scoring


    I have added the following to the /etc/spamassassin/local.cf file and restarted spamd (/etc/init.d/spamassassin restart), but nothing seems to have changed. When I send test emails that contain the specified search-words (from an address that is not white-listed) it doesn't get detected as spam and there is no x-spam-status header to see what scores it was given




    body LOCAL_LONELY_HOUSE_WIFE_RULE /Lonely House Wife/i
    score LOCAL_LONELY_HOUSE_WIFE_RULE 1.0

    body LOCAL_DATE_RULE /Date/i
    score LOCAL_DATE_RULE 0.5

    body LOCAL_DATING_RULE /Dating/i
    score LOCAL_DATING_RULE 0.5

    body LOCAL_FACEBOOK_PASHION_RULE /FacebookPassion.com/i
    score LOCAL_FACEBOOK_PASHION_RULE 1.0

    body LOCAL_DATINGHACKERS1_RULE /DatingHacker/i
    score LOCAL_DATINGHACKERS1_RULE 1.0

    header LOCAL_DATINGHACKERS2_RULE Subject =~ /DatingHacker/i
    score LOCAL_DATINGHACKERS2_RULE 1.0

    add_header spam Flag _YESNOCAPS_
    add_header all Status _YESNO_, score=_SCORE_ required=_REQD_ tests=_TESTS_ autolearn=_AUTOLEARN_ version=_VERSION_
    add_header all Level _STARS(*)_
    add_header all Checker-Version SpamAssassin _VERSION_ (_SUBVERSION_) on _HOSTNAME_
     
  2. till

    till Super Moderator

    ISPConfig uses amavisd for spam scanning and not spamd. If you want to reconfigure email spam scanning, please restart amavisd and not spamd.
     
  3. billcouper81

    billcouper81 New Member

    Thanks till

    Restarting amavis has made it pick up the changes I made to /etc/spamassassin/local.cf

    But it still won't show the scoring for emails that pass as being clean, is there any way to force the x-spam headers on ALL mail, not just spam ones?
     
  4. till

    till Super Moderator

    Set the spam score (1) in the spamfilter policy that you use in ispconfig to -100
     
  5. billcouper81

    billcouper81 New Member

    I cannot find such an option as "spam score"
     
  6. till

    till Super Moderator

    The field is named SPAM tag level.
     
  7. billcouper81

    billcouper81 New Member

    thanks till

    I have adjusted that field and it has the desired effect

    thankyou
     

Share This Page