Spamassassin doesn't work after update 2.2.36 on Lenny

Discussion in 'General' started by gscaglia, Aug 7, 2010.

  1. gscaglia

    gscaglia HowtoForge Supporter

    *SOLVED* Spamassassin doesn't work after update 2.2.36 on Lenny

    Hi there,
    I've updated the ISPConfig 2 panel on my production server (Debian Lenny) to 2.2.36 release and Spamassassin doesn't work.

    Before update worked perfectly and now it's dead.

    Any ideas?

    Thanks a lot,
    Luca
     
    Last edited: Aug 7, 2010
  2. gscaglia

    gscaglia HowtoForge Supporter

    Add information

    Before the update ISPConfig 2.2.36, in the headers of messagges, with Spam strategy set to discard, there was (for example):
    Code:
    X-Spam-Level: *****
    X-Spam-Status: No, score=5.8 required=9.0 tests=AWL,DNS_FROM_OPENWHOIS,
    	       FH_DATE_PAST_20XX,HTML_MESSAGE autolearn=no version=3.2.5
    Now in the headers messages there aren't any X-Spam header.

    I think that Spamassassin works in the system but it not scans any email.

    Help me please,
    Luca
     
  3. gscaglia

    gscaglia HowtoForge Supporter

    Solved

    I read the Rbatz, Punto and Till posts (http://www.howtoforge.com/forums/showthread.php?t=46184&page=3) and Spamassassin works!

    This is the simple solution:
    Code:
    /home/admispconfig/ispconfig/tools/spamassassin/usr/bin/sa-update
    If the sa-update script doesn't work, this is the Debian (Lenny) solution:
    Code:
    apt-get install libwww-perl
    Thanks to all and Regards
     

Share This Page