Spamassassin Channel update

Discussion in 'Installation/Configuration' started by wiss, Jul 28, 2011.

  1. wiss

    wiss Member

    Hy!!

    last few days I'm getting too much spam and when I updated spamassassin-d:
    Code:
    jul 28 12:13:58.157 [19350] dbg: logger: adding facilities: all
    jul 28 12:13:58.158 [19350] dbg: logger: logging level is DBG
    jul 28 12:13:58.158 [19350] dbg: generic: SpamAssassin version 3.3.1
    jul 28 12:13:58.158 [19350] dbg: generic: Perl 5.010001, PREFIX=/usr, DEF_RULES_DIR=/usr/share/spamassassin, LOCAL_RULES_DIR=/etc/spamassassin, LOCAL_STATE_DIR=/var/lib/spamassassin
    jul 28 12:13:58.158 [19350] dbg: config: timing enabled
    jul 28 12:13:58.159 [19350] dbg: config: score set 0 chosen.
    jul 28 12:13:58.168 [19350] dbg: dns: is Net::DNS::Resolver available? yes
    jul 28 12:13:58.168 [19350] dbg: dns: Net::DNS version: 0.65
    jul 28 12:13:58.168 [19350] dbg: generic: sa-update version svn917659
    jul 28 12:13:58.168 [19350] dbg: generic: using update directory: /var/lib/spamassassin/3.003001
    jul 28 12:13:58.296 [19350] dbg: diag: perl platform: 5.010001 linux
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Digest::SHA1, version 2.12
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: HTML::Parser, version 3.64
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Net::DNS, version 0.65
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: NetAddr::IP, version 4.024
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Time::HiRes, version 1.9719
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Archive::Tar, version 1.52
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: IO::Zlib, version 1.09
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Digest::SHA1, version 2.12
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: MIME::Base64, version 3.08
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: DB_File, version 1.82
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Net::SMTP, version 2.31
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Mail::SPF, version v2.007
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module not installed: IP::Country::Fast ('require' failed)
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module not installed: Razor2::Client::Agent ('require' failed)
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: Net::Ident, version 1.20
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: IO::Socket::INET6, version 2.54
    jul 28 12:13:58.297 [19350] dbg: diag: [...] module installed: IO::Socket::SSL, version 1.31
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module installed: Compress::Zlib, version 2.02
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module installed: Mail::DKIM, version 0.38
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module installed: DBI, version 1.609
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module installed: Getopt::Long, version 2.38
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module installed: LWP::UserAgent, version 5.834
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module installed: HTTP::Date, version 5.831
    jul 28 12:13:58.298 [19350] dbg: diag: [...] module not installed: Encode::Detect ('require' failed)
    jul 28 12:13:58.299 [19350] dbg: gpg: Searching for 'gpg'
    jul 28 12:13:58.299 [19350] dbg: util: current PATH is: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
    jul 28 12:13:58.299 [19350] dbg: util: executable for gpg was found at /usr/bin/gpg
    jul 28 12:13:58.299 [19350] dbg: gpg: found /usr/bin/gpg
    jul 28 12:13:58.299 [19350] dbg: gpg: release trusted key id list: 5E541DC959CB8BAC7C78DFDC4056A61A5244EC45 26C900A46DD40CD5AD24F6D7DEE01987265FA05B 0C2B1D7175B852C64B3CDC716C55397824F434CE
    jul 28 12:13:58.303 [19350] dbg: channel: attempting channel updates.spamassassin.org
    jul 28 12:13:58.303 [19350] dbg: channel: update directory /var/lib/spamassassin/3.003001/updates_spamassassin_org
    jul 28 12:13:58.303 [19350] dbg: channel: channel cf file /var/lib/spamassassin/3.003001/updates_spamassassin_org.cf
    jul 28 12:13:58.303 [19350] dbg: channel: channel pre file /var/lib/spamassassin/3.003001/updates_spamassassin_org.pre
    jul 28 12:13:58.303 [19350] dbg: channel: metadata version = 1151385
    jul 28 12:13:58.310 [19350] dbg: dns: 1.3.3.updates.spamassassin.org => 1151385, parsed as 1151385
    jul 28 12:13:58.310 [19350] dbg: channel: current version is 1151385, new version is 1151385, skipping channel
    jul 28 12:13:58.310 [19350] dbg: diag: updates complete, exiting with code 1
    
    I think that the rules are obsolete? no?

    this is an email was received yesterday. It was not rated as spam:
    Code:
    Return-Path: <[email protected]>
    Delivered-To: [email protected]
    Received: from localhost (localhost.localdomain [127.0.0.1])
    	by domain (Postfix) with ESMTP id 5466BC4031
    	for <[email protected]>; Wed, 27 Jul 2011 20:43:13 +0200 (CEST)
    X-Virus-Scanned: Debian amavisd-new at domain
    Received: from domain ([127.0.0.1])
    	by localhost (domain [127.0.0.1]) (amavisd-new, port 10024)
    	with ESMTP id pIvx1+4qln+N for <[email protected]>;
    	Wed, 27 Jul 2011 20:43:13 +0200 (CEST)
    Received: from corporat190-025217091.sta.etb.net.co (unknown [190.25.217.91])
    	by domain (Postfix) with ESMTP id EBD1FC4004
    	for <[email protected]>; Wed, 27 Jul 2011 20:43:12 +0200 (CEST)
    Received: from 190.25.217.91(helo=domain)
    	by domain with esmtpa (Exim 4.69)
    	(envelope-from )
    	id 1MM6DJ-9835lm-54
    	for <[email protected]>; Wed, 27 Jul 2011 13:43:11 -0500
    From: <[email protected]>
    To: <[email protected]>
    Subject: Administrative Assistant Position
    Date: Wed, 27 Jul 2011 13:43:11 -0500
    MIME-Version: 1.0
    Content-Type: text/plain;
    	charset="us-ascii"
    Content-Transfer-Encoding: 7bit
    X-Mailer: ikwrbegowi 80
    Message-ID: <[email protected]>
    
    We are currently looking to recruit Regional Representative to join our great team in EU!
    We are currently looking to recruit for a full-time or part-time position a person with varied experience and a strong desire to work.
    Candidates having 2-3 hours of spare time a day and holding European citizenship are preferred.
    
    We offer a competitive salary based on experience, free choice of working hours and fully paid training during a trial period.
    The Regional Representative job will involve working our clients providing appropriate service, updating database,
    assisting with certain company’s activities.
    
    More information can be provided after you send us your contact details and we will be able arrange a preliminary interview.
    Looking forward to hearing from you soon! 
    
    Our contacts:  [email protected]
    
    
    
    Thx so much.
     
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you try
    Code:
    sa-update --no-gpg
    to download the newest SpamAssassin rulesets?
     
  3. wiss

    wiss Member

    here is a otuput :

    Code:
    [email protected]:~# sa-update --no-gpg -D
    jul 29 11:47:20.786 [4507] dbg: logger: adding facilities: all
    jul 29 11:47:20.786 [4507] dbg: logger: logging level is DBG
    jul 29 11:47:20.786 [4507] dbg: generic: SpamAssassin version 3.3.1
    jul 29 11:47:20.786 [4507] dbg: generic: Perl 5.010001, PREFIX=/usr, DEF_RULES_DIR=/usr/share/spamassassin, LOCAL_RULES_DIR=/etc/spamassassin, LOCAL_STATE_DIR=/var/lib/spamassassin
    jul 29 11:47:20.786 [4507] dbg: config: timing enabled
    jul 29 11:47:20.787 [4507] dbg: config: score set 0 chosen.
    jul 29 11:47:20.796 [4507] dbg: dns: is Net::DNS::Resolver available? yes
    jul 29 11:47:20.796 [4507] dbg: dns: Net::DNS version: 0.65
    jul 29 11:47:20.796 [4507] dbg: generic: sa-update version svn917659
    jul 29 11:47:20.797 [4507] dbg: generic: using update directory: /var/lib/spamassassin/3.003001
    jul 29 11:47:20.925 [4507] dbg: diag: perl platform: 5.010001 linux
    jul 29 11:47:20.925 [4507] dbg: diag: [...] module installed: Digest::SHA1, version 2.12
    jul 29 11:47:20.925 [4507] dbg: diag: [...] module installed: HTML::Parser, version 3.64
    jul 29 11:47:20.925 [4507] dbg: diag: [...] module installed: Net::DNS, version 0.65
    jul 29 11:47:20.925 [4507] dbg: diag: [...] module installed: NetAddr::IP, version 4.024
    jul 29 11:47:20.925 [4507] dbg: diag: [...] module installed: Time::HiRes, version 1.9719
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Archive::Tar, version 1.52
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: IO::Zlib, version 1.09
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Digest::SHA1, version 2.12
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: MIME::Base64, version 3.08
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: DB_File, version 1.82
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Net::SMTP, version 2.31
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Mail::SPF, version v2.007
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module not installed: IP::Country::Fast ('require' failed)
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module not installed: Razor2::Client::Agent ('require' failed)
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Net::Ident, version 1.20
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: IO::Socket::INET6, version 2.54
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: IO::Socket::SSL, version 1.31
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Compress::Zlib, version 2.02
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: Mail::DKIM, version 0.38
    jul 29 11:47:20.926 [4507] dbg: diag: [...] module installed: DBI, version 1.609
    jul 29 11:47:20.927 [4507] dbg: diag: [...] module installed: Getopt::Long, version 2.38
    jul 29 11:47:20.927 [4507] dbg: diag: [...] module installed: LWP::UserAgent, version 5.834
    jul 29 11:47:20.927 [4507] dbg: diag: [...] module installed: HTTP::Date, version 5.831
    jul 29 11:47:20.927 [4507] dbg: diag: [...] module not installed: Encode::Detect ('require' failed)
    jul 29 11:47:20.931 [4507] dbg: channel: attempting channel updates.spamassassin.org
    jul 29 11:47:20.931 [4507] dbg: channel: update directory /var/lib/spamassassin/3.003001/updates_spamassassin_org
    jul 29 11:47:20.931 [4507] dbg: channel: channel cf file /var/lib/spamassassin/3.003001/updates_spamassassin_org.cf
    jul 29 11:47:20.931 [4507] dbg: channel: channel pre file /var/lib/spamassassin/3.003001/updates_spamassassin_org.pre
    jul 29 11:47:20.931 [4507] dbg: channel: metadata version = 1151767
    jul 29 11:47:20.938 [4507] dbg: dns: 1.3.3.updates.spamassassin.org => 1151767, parsed as 1151767
    jul 29 11:47:20.938 [4507] dbg: channel: current version is 1151767, new version is 1151767, skipping channel
    jul 29 11:47:20.938 [4507] dbg: diag: updates complete, exiting with code 1
    
    Thx
     
  4. wiss

    wiss Member

    I found that all spma emails have similar header:
    Code:
    Return-Path: <[B]0-[/B][email protected]>
    All begining with 0-

    Then, when i create a rule for this header?

    Thx.
     
  5. falko

    falko Super Moderator ISPConfig Developer

    Does
    Code:
    spamassassin --lint
    show any output? Do you see any amavisd errors in your mail log when you restart amavisd?
     
  6. wiss

    wiss Member

    hy falko.

    Code:
    [email protected]:~# spamassassin --lint
    [email protected]:~# 
    
    no output

    i restart amavisd and checked mail log. I haven't found any erros in log

    Yesterday after
    Code:
    sa-update --no-gpg
    I don't receive any spam, i think that problem is solved.

    Thx falko.!!!
     

Share This Page