spamassassin 100%

Discussion in 'Installation/Configuration' started by bwragg, Sep 18, 2008.

  1. bwragg

    bwragg New Member


    I regularly have one or more spamassassin process on my ISPConfig system which run at 100% and I can't seem to see why. For example here is one I found this morning:

    8717 10076     25   0 72284  42m 2580 R  100  1.1   1:07.72 spamassassin
    27710 10076     25   0 72208  42m 2580 R  100  1.1 502:29.76 spamassassin
    As you can see one has been runing for 502 minutes. I know for sure I'm not under some type of spam attack, I've checked the maillog and no mail is coming in. The slow down from this is massive, we have a 2 dual core cpus and each process will add 25% load on the cpus, so if I have 3 of these runing top reports the total cpu usage is 75%. If I do a kill -9 on the processes they disappear and all is fine. But within a few hours another one is back there running at 100%.

    Any idea what causes this to run like this? Were running Centos 4.6 and have applied the ispconfig mod so that we run clamd.


    Last edited: Sep 18, 2008
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Clamd and spamassassin are two completely different software packages, so if you run clamav as clamd or clamscan has no influence on spamassassin.

    If you want to run spamassassin as spamd, install spamd from your linux distribution and the reconfigure the spamassassin procmail recipe in /root/ispconfig/isp/conf/ to use the spamd from your linux distribution.
  3. bwragg

    bwragg New Member

    Thanks till. I only mentioned the clamd update because I noticed that quite a few threads with this spamassassin problem suggested to upgrade the clamd as well.

    From what you said here:

    It sounds like spamd run more stable? Is there any negatives with configuring and using spamd instead of normal spamassassin binary?


  4. till

    till Super Moderator Staff Member ISPConfig Developer

    This is not about stability. Spamd is just faster as it does not has to load the libraries again for every mail to be scanned.

  5. bwragg

    bwragg New Member

    My original question was about stability. Spamassassin processes don't shutdown they build up until they take up 100% of my cpu (if I dont kill them). This is even when there is no mail coming in i.e nothing showing in the mail logs.

    Any idea what causes it to run like this? Would setting up the system to run using a spamd process help?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    You should try spamd as I suggested.

Share This Page