Spamassasin

Discussion in 'Installation/Configuration' started by progressed36, Jun 15, 2017.

  1. progressed36

    progressed36 New Member

    Hi There,
    I completed the upgrade to 17.04 and the latest ISPConfig. After this completion i have a rather strange problem... well 2 actually but lets start with the mail.

    Got some clients complaining about mail not being delivered to them and tagged as SPAM when it is not since the upgrade. WHen i checked a simple hotmail message got tagged by ISPconfig when the level is well see for yourself:
    X-Virus-Scanned: Debian amavisd-new at MAIL*****.***.EU
    X-Spam-Flag: YES
    X-Spam-Score: 1.088
    X-Spam-Level: *
    X-Spam-Status: Yes, score=1.088 tagged_above=0 required=0
    tests=[DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1,
    FORGED_HOTMAIL_RCVD2=1.187, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001,
    RCVD_IN_DNSWL_NONE=-0.0001, SPF_HELO_PASS=-0.001, SPF_PASS=-0.001,
    URIBL_BLOCKED=0.001] autolearn=no autolearn_force=no

    Because of the complaints i losent the spamtag settings, but looking at these scores i didnt have to! I returned the settings and now im running to you. These are my pokicy settings:

    https://ibb.co/d1CYf5
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    ensure to set the spamfilter policy for the domain as well and not just the mailbox (or for the domain only should be enough in case that all mailboxes shall use this policy anyway). The reason is this, when an email is received trough an alias, then this alias gets checked for the policy that shall be assigned and not the target mail address. so by setting the policy for the domain, you track all aliases as well.
     
  3. Progressed

    Progressed New Member

    It is set on the domain. The crazy part is... even internal email is marked as SPAM. From the own server :/

    X-Virus-Scanned: Debian amavisd-new at MAIL***.***.EU
    X-Spam-Flag: YES
    X-Spam-Score: 1.979
    X-Spam-Level: *
    X-Spam-Status: Yes, score=1.979 tagged_above=0 required=0
    tests=[ALL_TRUSTED=-1, DC_PNG_UNO_LARGO=0.001,
    HTML_IMAGE_ONLY_32=0.001, HTML_IMAGE_RATIO_02=0.805,
    HTML_MESSAGE=0.001, HTML_TITLE_SUBJ_DIFF=2.171]
    autolearn=no autolearn_force=no
     
  4. Progressed

    Progressed New Member

    I have to stress out that this is not a settings thing. It was running very smoothly... It happened after updating 8th of june.
     
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you run an ispconfig update with reconfigure services after the upgrade? if not, then do that. otherwise the dist upgrade might have overridden config settings from ispconfig.
     
  6. Progressed

    Progressed New Member

    i did the dist upgrade before i did an ISPconfig_update.sh :) but i will do it again... no problem! be back with you shortly
     
  7. Progressed

    Progressed New Member

    Ok i have done it. Rebooted the system and look here a standard message from hotmail got tagged by spam:

    X-Spam-Status: Yes, score=1.068 tagged_above=0 required=0
    tests=[DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1,
    FORGED_HOTMAIL_RCVD2=1.187, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001,
    RCVD_IN_MSPIKE_H4=-0.01, RCVD_IN_MSPIKE_WL=-0.01,
    SPF_HELO_PASS=-0.001, SPF_PASS=-0.001, URIBL_BLOCKED=0.001]
    autolearn=no autolearn_force=no
     
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Try to increase the log level in the amavis config to see in mail.log where amavis gets the '0' tag levels from. The ispconfig version is 3.1.3? I remember that amavis had some issues with column types in the table that contains the spamfilter policies so that we had to change the type a few releases ago to make it work again with latest amavis versions. maybe this is somehow related.
     
  9. Progressed

    Progressed New Member

    Well my guess is the 0 tag levels are correct. Why are they marked as SPAM even tough its way below 3?!
     
  10. Progressed

    Progressed New Member

    i looking at a logfile and have to idea what im searching for.
     
  11. till

    till Super Moderator Staff Member ISPConfig Developer

    required=0 means tag when the score is above 0 and not when the score is above 3, that's why I recommended looking at the log file after setting a higher log level in amavis to see where it gets the required 0 score from.
     
  12. Progressed

    Progressed New Member

    Thats what i did. I get allot of log lines but i dont see WHY it is spam. (i set it to 5)

    Jun 15 18:43:13 MAILS**& amavis[2890]: (02890-01) header encoded (all-ASCII): X-Spam-Status: Yes,\n score=2.693\n tagged_above=0\n required=0\n tests=[DKIM_SIGNED=0.1,\n DKIM_VALID=-0.1,\n DKIM_VALID_AU=-0.1,\n FORGED_HOTMAIL_RCVD2=1.187,\n FREEMAIL_FROM=0.001,\n HTML_MESSAGE=0.001,\n RCVD_IN_DNSWL_NONE=-0.0001,\n RCVD_IN_MSPIKE_H3=-0.01,\n RCVD_IN_MSPIKE_WL=-0.01,\n SPF_HELO_PASS=-0.001,\n SPF_PASS=-0.001,\n SUBJ_ALL_CAPS=1.625,\n URIBL_BLOCKED=0.001]\n autolearn=no autolearn_force=no
    Jun 15 18:43:13 MAIL*** amavis[2890]: (02890-01) header: X-Spam-Status: Yes, score=2.693 tagged_above=0 required=0\n\ttests=[DKIM_SIGNED=0.1, DKIM_VALID=-0.1, DKIM_VALID_AU=-0.1,\n\tFORGED_HOTMAIL_RCVD2=1.187, FREEMAIL_FROM=0.001, HTML_MESSAGE=0.001,\n\tRCVD_IN_DNSWL_NONE=-0.0001, RCVD_IN_MSPIKE_H3=-0.01,\n\tRCVD_IN_MSPIKE_WL=-0.01, SPF_HELO_PASS=-0.001, SPF_PASS=-0.001,\n\tSUBJ_ALL_CAPS=1.625, URIBL_BLOCKED=0.001]\n\tautolearn=no autolearn_force=no\n
     
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    It is spam because 2.693 is > 0: score=2.693 tagged_above=0

    The log above the part you posted shows you where amavis got the 0 score from.

    and you did not answer my questions about the ispconfig version.
     
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    and check with e.g. phpmyadmin which data type the columns spam_tag_level and spam_tag2_level in the spamfilter_policy table of the dbispconfig database have.
     
  15. Progressed

    Progressed New Member

    I did tell you. look at the very first post. "I completed the upgrade to 17.04 and the latest ISPConfig."

    Here you have the export of the Spam line i use:
    "3","1","0","riud","riud","r","Wants all spam","Y","Y","Y","Y","N","N","N","N","Y",,,,,,,"3.1","3.6","5","0","0",,,,,"N","N","N",,,,,,"[SPAM]","[SPAM]","0",,"-1","24","-1","24","N"
     
  16. till

    till Super Moderator Staff Member ISPConfig Developer

    I asked for the data type of the columns, not the data stored in it.

    Some people say latest ISPConfig to git master version, others say latest to git stable 3.1 branch and another users says latest to the actual released stable code from the tar.gz. so what did you install, 3.1.3 ?
     
  17. Progressed

    Progressed New Member

    I asked for the data type of the columns, not the data stored in it.
    spam_tag_level float YES NULL
    spam_tag2_level float YES NULL

    Some people say latest ISPConfig to git master version, others say latest to git stable 3.1 branch and another users says latest to the actual released stable code from the tar.gz. so what did you install, 3.1.3 ?
    Yes, I upgraded to 3.1.3.
     
  18. till

    till Super Moderator Staff Member ISPConfig Developer

    Type float should be fine and version 3.1.3 as well. You should try to read trough the log output, amavis explains there from which source (which policy or a config file) it gets the score levels.

    If you can't find it yourself, consider to contact Florian from Business support team to check it by remote login: http://www.ispconfig.org/get-support/?type=ispconfig
     
  19. Progressed

    Progressed New Member

Share This Page