***SPAM*** Welcome to your new email account

Discussion in 'Server Operation' started by KZeeSoft, Jun 10, 2010.

  1. KZeeSoft

    KZeeSoft New Member

    Hellow everyone!

    I had a mail problem where I couldn't send mail outside my server, and attempted to change the port from the default of 25 to 587. (My ISP blocks port 25 on outgoing connections) I attempted numerous ways, but failed to do so and I had to keep going back to the backups to restore my server for web operation and incoming mail.

    I still had the same issue for 3 weeks, so I just started over and rebuilt it again with the "Perfect Server Debian Lenny w/ ISPC 3". I followed everything as I did before, making minor adjustments that were suggested. I thought this would resolve, but I still have the same issue. When I create a new mail account using ISP Config 3, and get the confirmation email sent from ISP Config 3, it marks it as ***SPAM*** Welcome to your new email account."

    Why is the server still hating itself in terms of spam? Is there a way to change the SMTP port from 25 -> 587 so I can send mail again? Tell me what info you need and I'll post it.

    Thanks for the help everyone!
  2. falko

    falko Super Moderator ISPConfig Developer

    Does the email header include any details about the spam scores?
  3. KZeeSoft

    KZeeSoft New Member

    Here is the full header info:

    Return-Path: <[email protected]>
    Delivered-To: [email protected]
    Received: from localhost (localhost.localdomain [])
         by alphaserver1.sufuku.net (Postfix) with ESMTP id 02497108799
         for <[email protected]>; Tue, 18 May 2010 12:12:51 -0400 (EDT)
    X-Virus-Scanned: Debian amavisd-new at alphaserver1.sufuku.net
    X-Spam-Flag: NO
    X-Spam-Score: 1.406
    X-Spam-Level: *
    X-Spam-Status: No, score=1.406 tagged_above=1 required=4.5
         tests=[NO_DNS_FOR_FROM=1.407, NO_RELAYS=-0.001]
    Received: from alphaserver1.sufuku.net ([])
         by localhost (alphaserver1.sufuku.net []) (amavisd-new, port 10024)
         with ESMTP id pK55Mq95SE+b for <[email protected]>;
         Tue, 18 May 2010 12:12:51 -0400 (EDT)
    Received: by alphaserver1.sufuku.net (Postfix, from userid 33)
         id 3FC4A108797; Tue, 18 May 2010 12:12:51 -0400 (EDT)
    To: [email protected]
    MIME-Version: 1.0
    Content-type: text/plain; charset=iso-8859-1
    From: ISPConfig3 <[email protected]>
    Reply-To: <[email protected]>
    Message-Id: <[email protected]>
    Date: Tue, 18 May 2010 12:12:51 -0400 (EDT)
  4. falko

    falko Super Moderator ISPConfig Developer

    There's no DNS record for alphaserver1.sufuku.net:

    mh1:~# dig alphaserver1.sufuku.net
    ; <<>> DiG 9.3.4 <<>> alphaserver1.sufuku.net
    ;; global options:  printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 31119
    ;; flags: qr aa rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;alphaserver1.sufuku.net.       IN      A
    ;; Query time: 222 msec
    ;; SERVER:
    ;; WHEN: Sat Jun 12 16:41:28 2010
    ;; MSG SIZE  rcvd: 41
    Please create one.
  5. KZeeSoft

    KZeeSoft New Member

    Was this something new this year?

    When I set my first server up months ago, this step wasn't needed, unless I missed something?

    The DNS records I had to set where only in GoDaddy (where my domain name was registered) like the MX Record etc...

    So I would setup the DNS record in the ISP Config Control Panel instead of GoDaddy? I only have one IP address, so I thought I couldn't host my own DNS (unless you have two or more)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please edit the spam rule(s) in ispconfig, so that tag level is empty and tag2 level is set to ***SPAM***.
  7. KZeeSoft

    KZeeSoft New Member


    I have set that so now my server does not say SPAM anymore. Wonderful Till, thank you!

    Is there anyway to change the port to send mail from 25 -> 587? I have to do this because my ISP is blocking port 25 and I can't send mail.


    I have tried to add DNS records, but I still can't get that portion to recognize my server / mail server, where it did work before without adding these records. I use GoDaddy to host the DNS until I can get another server and another IP address to host my own DNS. Is there some way to do this with only one IP? If so, do tell! =)

  8. till

    till Super Moderator Staff Member ISPConfig Developer

  9. KZeeSoft

    KZeeSoft New Member

    OK, I changed the port by doing what that link said. BUT, even though I uncommented that line, it seems as though POSTFIX is still trying to send on port 25! See below:

    Jun 15 09:11:40 alphaserver1 postfix/smtp[24726]: connect to vztpa.verizon.com[]:25: Connection timed out
    Jun 15 09:12:10 alphaserver1 postfix/smtp[24726]: connect to vzsac.verizon.com[]:25: Connection timed out
    Jun 15 09:12:40 alphaserver1 postfix/smtp[24726]: connect to vzsac.verizon.com[]:25: Connection timed out
    Jun 15 09:13:10 alphaserver1 postfix/smtp[24726]: connect to vzsac.verizon.com[]:25: Connection timed out
    Jun 15 09:13:10 alphaserver1 postfix/smtp[24726]: 9107F10881C: to=, relay=none, delay=150, delays=0.01/0.01/150/0, dsn=4.4.1, status=deferred (connect to vzsac.verizon.com[]:25: Connection timed out)
    Jun 15 09:14:52 alphaserver1 postfix/qmgr[24518]: B51FA10881A: from=, size=1252, nrcpt=1 (queue active)
    I still can't send mail! Is there a way to make POSTFIX use 587 all the time, instead of 25 as default? Yes, I have restarted POSTFIX after making the changes =)
  10. KZeeSoft

    KZeeSoft New Member

    After three days, my server still is sending through port 25!

    Here is my /etc/postfix/master.cf:
    # Postfix master process configuration file.  For details on the format
    # of the file, see the master(5) manual page (command: "man 5 master").
    # Do not forget to execute "postfix reload" after editing this file.
    # ==========================================================================
    # service type  private unpriv  chroot  wakeup  maxproc command + args
    #               (yes)   (yes)   (yes)   (never) (100)
    # ==========================================================================
    smtp       inet  n       -       -       -       -       smtpd
    submission inet  n       -       -       -       -       smtpd
      -o smtpd_tls_security_level=encrypt
      -o smtpd_sasl_auth_enable=yes
      -o smtpd_client_restrictions=permit_sasl_authenticated,reject
      -o milter_macro_daemon_name=ORIGINATING
    587        inet  n       -       -       -       -       smtpd
    #smtps     inet  n       -       -       -       -       smtpd
    #  -o smtpd_tls_wrappermode=yes
    #  -o smtpd_sasl_auth_enable=yes
    #  -o smtpd_client_restrictions=permit_sasl_authenticated,reject
    #  -o milter_macro_daemon_name=ORIGINATING
    #628      inet  n       -       -       -       -       qmqpd
    pickup    fifo  n       -       -       60      1       pickup
    cleanup   unix  n       -       -       -       0       cleanup
    qmgr      fifo  n       -       n       300     1       qmgr
    #qmgr     fifo  n       -       -       300     1       oqmgr
    tlsmgr    unix  -       -       -       1000?   1       tlsmgr
    rewrite   unix  -       -       -       -       -       trivial-rewrite
    bounce    unix  -       -       -       -       0       bounce
    defer     unix  -       -       -       -       0       bounce
    trace     unix  -       -       -       -       0       bounce
    verify    unix  -       -       -       -       1       verify
    flush     unix  n       -       -       1000?   0       flush
    proxymap  unix  -       -       n       -       -       proxymap
    proxywrite unix -       -       n       -       1       proxymap
    smtp      unix  -       -       -       -       -       smtp
    # When relaying mail as backup MX, disable fallback_relay to avoid MX loops
    relay     unix  -       -       -       -       -       smtp
            -o smtp_fallback_relay=
    #       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
    showq     unix  n       -       -       -       -       showq
    error     unix  -       -       -       -       -       error
    retry     unix  -       -       -       -       -       error
    discard   unix  -       -       -       -       -       discard
    local     unix  -       n       n       -       -       local
    virtual   unix  -       n       n       -       -       virtual
    lmtp      unix  -       -       -       -       -       lmtp
    anvil     unix  -       -       -       -       1       anvil
    scache    unix  -       -       -       -       1       scache
    # ====================================================================
    # Interfaces to non-Postfix software. Be sure to examine the manual
    # pages of the non-Postfix software to find out what options it wants.
    # Many of the following services use the Postfix pipe(8) delivery
    # agent.  See the pipe(8) man page for information about ${recipient}
    # and other message envelope options.
    # ====================================================================
    # maildrop. See the Postfix MAILDROP_README file for details.
    # Also specify in main.cf: maildrop_destination_recipient_limit=1
    maildrop  unix  -       n       n       -       -       pipe
      flags=DRhu user=vmail argv=/usr/bin/maildrop -d vmail ${extension} ${recipient} ${user} ${nexthop} ${sender}
    # See the Postfix UUCP_README file for configuration details.
    uucp      unix  -       n       n       -       -       pipe
      flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
    # Other external delivery methods.
    ifmail    unix  -       n       n       -       -       pipe
      flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
    bsmtp     unix  -       n       n       -       -       pipe
      flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
    scalemail-backend unix  -       n       n       -       2       pipe
      flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
    mailman   unix  -       n       n       -       -       pipe
      flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
      ${nexthop} ${user}
    amavis unix - - - - 2 smtp
            -o smtp_data_done_timeout=1200
            -o smtp_send_xforward_command=yes inet n - - - - smtpd
            -o content_filter=
            -o local_recipient_maps=
            -o relay_recipient_maps=
            -o smtpd_restriction_classes=
            -o smtpd_client_restrictions=
            -o smtpd_helo_restrictions=
            -o smtpd_sender_restrictions=
            -o smtpd_recipient_restrictions=permit_mynetworks,reject
            -o mynetworks=
            -o strict_rfc821_envelopes=yes
            -o receive_override_options=no_unknown_recipient_checks,no_header_body_checks
            -o smtpd_bind_address=
    Output of telnet localhost 587:
    telnet localhost 587
    Connected to localhost.
    Escape character is '^]'.
    220 alphaserver1.sufuku.net ESMTP Postfix (Debian/GNU)
    ehlo localhost
    250 DSN
    221 2.0.0 Bye
    Connection closed by foreign host.
    Should I be uncommenting the option flags after submission or smtps to enable port 587 as the default smtp port or not? What am I missing?
    Last edited: Jun 18, 2010
  11. KZeeSoft

    KZeeSoft New Member

    Here is the delivery report for the emails that don't send out. I know they are timing out because they are still sending on port 25, so how do I disable port 25 for sending, and keep 587 as the default for sending!

    Reporting-MTA: dns; alphaserver1.sufuku.net
    X-Postfix-Queue-ID: B51FA10881A
    X-Postfix-Sender: rfc822; [email protected]
    Arrival-Date: Tue, 15 Jun 2010 09:05:33 -0400 (EDT)
    Final-Recipient: rfc822; [email protected]
    Original-Recipient: rfc822;[email protected]
    Action: failed
    Status: 4.4.1
    Diagnostic-Code: X-Postfix; connect to
        alt4.gmail-smtp-in.l.google.com[]:25: Connection timed out
    See my previous post for other command outputs, am I missing something in my /etc/postfix/master.cf?
  12. KZeeSoft

    KZeeSoft New Member

    Last attempt at fixing this port 25 issue!

    I think I understand what is wrong!

    I know this:

    - My ISP started blocking port 25 recently, which stopped my emails from getting out.

    - My ISP said to start using port 587, because that is still open

    - I tried to change the port to 587, but someone told me that Server -> Server communication for mail can only exist on port 25, is this correct?

    If so, this is why I cannot send mail, and why it is still trying to send on port 25 as opposed to 587.

    Can anyone verify this, or is there a way to send mail to another mail server NOT on port 25?
  13. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, thats correct. Port 587 is only for connections from client > server and not server > server.

    But most providers allow connections on port 25 to their own mailserver even if they block port 25 for connections to all other servers. You should ask your provider if thats the case too in their setup. Because then you could use the mailserver of your provider as relay for your mailserver.

Share This Page