Spam stats

Discussion in 'Tips/Tricks/Mods' started by chasxmd, Apr 14, 2008.

  1. chasxmd

    chasxmd New Member

    Hello,

    I've tried/am using Munin, AwStats, and MailGraph (which I highly recommend). I just can't seem to get the stat's I want. I want a graph or some kind of stats displaying how many valid e-mails vs. e-mail's tagged spam come through my server. Has anyone ran into something they really like or can recomment?

    I recently installed ispconfig about a month ago and despite the long hours of trying to tweak it to my liking I'm very happy with it. I am running the latest stable on Fedora Core 8.

    Thanks you,
    Charles
     
  2. chasxmd

    chasxmd New Member

  3. mumbly

    mumbly New Member

    Don't work ...

    Hi !
    Thanx for the trick ...
    but it seems it does not work with Ubuntu 8.04 Hardy Heron ...
    this is not the same paths ... and there is no /etc/mail/spamassassin/ repository ...

    The database is filled correctly (as i can see spam field increasing) but there is no graph on the Reports/spam statistics page !
    Moreover, the summury are empty :

    The summary of analysis for today (since midnight local time);
    A total volume of 0 email messages have been processed in the past 10 hours.
    Of these, 0 messages (0.00%) have been rejected as spam.
    The remaining 0 messages were processed and routed as mail.

    ... but i know there are more than 15 spam in the last few minutes ...

    Any idea ?
    THANX !
     
    Last edited: May 9, 2008
  4. falko

    falko Super Moderator

    Did you switch off Apparmor?
     
  5. mumbly

    mumbly New Member

    Yes !!!
    Apparmor is switched off
    I've redone /etc/init.d/apparmor stop to be sure ...
    But the graphs and the stats are still empty
    And that's what i have in MySQL :
    day username domain spam ham
    2008-05-09 web1_admins2ii 152 4
    2008-05-09 web1_mumbly 68 1
    2008-05-10 web1_admins2ii 79 0
    2008-05-10 web1_mumbly 37 1
     
  6. falko

    falko Super Moderator

    Any errors in your logs?
     
  7. mumbly

    mumbly New Member

    No errors in my logs ...
    I've installed again spamstats on another server with Ubuntu 8.04 and this is the same result ...
    Hard luck ...
    PS : i must say that the .pkg file did not install the spam database correctly. I had to do it by hand ...
     
  8. mumbly

    mumbly New Member

    IT WORKS !
    In fact, the pkg file did not instal all the requested files : Stats.pm was not installed at all and local.cf was not updated with the spamstats SQL infos.
    I have just read the readme file included in the pkg file and it was the clear for me ! :)
    Moreover, the readme file says that one must do some "changes" for the spamassassin "server" AND for the spamassassin ispconfig. as i have no spamassassin "server" following the perfect server setup, it has mistaken me for some times ...
    But it's clearer now ! ;)
    ... and the mysql database was NOT installed at all ! I've done it by hand !
    Do some other people had the same issue ???
     
  9. MTvermoes

    MTvermoes New Member

    Problems after install (CentOS Perfect Setup):

    Viewing report after install (Clicking 'Spam Statistics') :

    MSIE : Stats is Reported OK, but the flash graphs just shows the loading anim.

    Firefox : Left frame (where the 'Spam Statistics' Link is located) just turns blank.

    Any Quick Fixes :confused:

    /Mark
     

Share This Page