spam seem not work

Discussion in 'Installation/Configuration' started by Michaeltc, Apr 27, 2018.

  1. Michaeltc

    Michaeltc New Member

    Dear All :

    I have try to follow the below link
    to set up mail server with anti-spam

    After confirm complete , I confirm amavisd.service is running, can I have add email domain email and set the Spamfilter is "normal",
    when I try to use gmail to send test to me, I receive the email, but email header have not any x-spam inside.
    The header only mention this
    Received: from localhost (localhost [])
    by (Postfix) with ESMTP id A81D3581C4
    for <[email protected]>; Fri, 27 Apr 2018 16:25:59 +0800 (HKT)
    X-Virus-Scanned: amavisd-new at
    Authentication-Results: (amavisd-new);
    dkim=pass (2048-bit key)
    Received: from ([])
    by localhost ( []) (amavisd-new, port 10024)
    with ESMTP id vzyJid_DuRE3 for <[email protected]>;
    Fri, 27 Apr 2018 16:25:58 +0800 (HKT)
    Received: from ( [])
    by (Postfix) with ESMTPS id 896EA581C1
    for <[email protected]>; Fri, 27 Apr 2018 16:25:58 +0800 (HKT)
    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;;

    Is that any missing inside? as we suppose the mail header should have
    X-Spam-Flag: NO
    X-Spam-Score: 5.628
    X-Spam-Level: *****
    X-Spam-Status: No, score=5.628 tag=3 tag2=6.9 kill=6.9

    Thank you
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The X-Spam settings are set when the spam score of an email exceeds the spam tag 1 score of the policy that you assigned to the mailbox. If you receive this email trough an email alias, then you should set the spam policy for the email domain as well.
  3. Michaeltc

    Michaeltc New Member

    Thanks I have solved it when the tag set to -999 then all email will get x-score

Share This Page